11

Currently I like to start a terminal without mouse moves by

  1. Alt-F2
  2. type in gnome-term
  3. press TAB to get gnome-terminal auto-completion
  4. Enter to start a terminal

However, this approach always provides a terminal that is not in fullscreen mode and has a menubar. Is it possible to change this behavior while keeping the simple steps described above?

Update:

There are two related questions here and here, but they are not as simple as I want: NO MOUSE MOVE and TAB completion. (I'm not sure if Compiz will do these, but I personally think installing Compiz doesn't seem to be a clean and simple solution)

3
  • Gnome terminal has a profile manager built into it. If you open gnome terminal, then select Edit -> profile preferences -> General, there is an option that is probably unchecked called "Use Custom Default Terminal Size". You can manipulate that to be as close to full screen as you want. Then click close. You should now be able to open and close the terminal any way you choose, and it will start in that size mode.
    – sanimalp
    Commented Oct 22, 2015 at 21:26
  • @sanimalp what about hiding menubar automatically?
    – wlnirvana
    Commented Oct 22, 2015 at 22:03
  • The menu bar can also be configured to be hidden, it's at Edit -> Preferences -> Show menubar by default in new terminals. You'll still get the window decoration though, you need --fullscreen if you want to start in real full screen mode without any chrome around the terminal area.
    – egmont
    Commented Oct 24, 2015 at 9:47

6 Answers 6

14

gnome-terminal --full-screen does what you want, although it is more keypresses than launching gnome-terminal and then pressing F11 to enter fullscreen mode.

You might, of course, create a wrapper binary called gt or whatever name you prefer:

#!/bin/sh
exec gnome-terminal --full-screen "$@"

Place it in your ~/bin directory and give it executable permissions.

6
  • Athough this solution does work, my situation is that I don't have root access... That's why I want a clean solution without installing new packages or changing bin directory...
    – wlnirvana
    Commented Oct 24, 2015 at 22:33
  • You don't need root access to create a script under your personal bin subdirectory of your home dir which I suggested to you.
    – egmont
    Commented Oct 25, 2015 at 5:24
  • that doesn't work... after export the personal bin to path, I can start gt from within a gnome-terminal, but not the Alt-F2 run application way...
    – wlnirvana
    Commented Oct 26, 2015 at 11:15
  • Setting PATH in .profile solved the problem. Thank you very much!
    – wlnirvana
    Commented Oct 27, 2015 at 10:40
  • Your gt is not a binary:) It's a text file (a script / a program / an executable but not a binary).
    – bloody
    Commented Mar 20, 2020 at 8:36
2
  1. Open the ~/.bash_aliases file with an editor of your choosing.
  2. Add this line alias gnome-terminal='gnome-terminal --full-screen'
  3. Either restart the terminal or type in source ~/.bash_aliases
  4. Create a custom keyboard shortcut (via Ubuntu GUI, no need for fancy terminal commands) and set the shortcut to Ctrl + Alt + T.
1

For CentOS 8 - Stream I have made size as 95x65 by brute force.

Also, menu hidden with Right-click preferences. And untick the default menu option.

Finally a shortcut added Ctrl + Shift + T

From Settings Shortcut for CentOS 8 Stream Terminal

For adding this shortcut - follow above steps, which is common in CentOS. But implemntation is added in this answer.

Terminal shortcut settings

2
  • Since this is a Ubuntu only support site do you know for a 100 percent sure that a CentOS answer works?
    – David DE
    Commented Mar 16, 2022 at 14:23
  • you check the screenshot. Commented Mar 16, 2022 at 18:16
0

As for an "anti-mouse" command line operator, why won't you get things yet more automated and put the terminal to your Startup applications?

  1. press Alt+F2 and type: gnome-session-p
  2. press Tab to get: gnome-session-properties and press Enter;
  3. Click Add and type in the Command field: gnome-terminal --full-screen
  4. Click Save;

From now on each time you boot your Ubuntu you will get the terminal launched in the full screen mode. Whenever you want to reach the desktop behind press F11 to bring the terminal into a window.

0

How about:

xdotool key F11 in .bashrc

Would this work?

Comment it out if you don't want it to start up like that

1
  • Did you try it? This will apply on any virtual terminal and on every nonlogin shell, and will toggle if using the same window (for e.g. using tabs or a screen manager). Commented Oct 12, 2022 at 19:28
0

You can copy /usr/share/applications/org.gnome.Terminal.desktop

To /home/<YOUR_USERNAME>/.local/share/applications/org.gnome.Terminal.desktop

And modify its content, so the terminal will run in fullscreen mode.

[Desktop Entry]
...
Exec=gnome-terminal --full-screen
...

Now, to run the terminal in full screen, you just need to hit super, start typing term..., and hit enter.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .