3

Just upgraded a 3rd Gen Lenovo Carbon X1 from 15.04 to 15.10 and I noticed a rise in CPU usage.

/usr/sbin/NetworkManager is using ~35% constantly and /lib/systemd/systemd-journald seems to rise when NetworkManager is started (drops when it is stopped).

Turning of the wireless adapter does nothing. Turning off bluetooth also does nothing. No LAN is connected.

Stopping the service fixes the problem, obviously, but this is not a viable option.

2

Turns out I had a custom config file

/etc/NetworkManager/dnsmasq.d/local

with one line

cache-size=300

When I removed this file (experimenting), network manager instantly stopped using CPU and returned to normal. The problem seems to be fixed.

8
  • It's magic! ...
    – o9000
    Oct 23 '15 at 0:16
  • I have the same problem after upgrading to 15.10. I have an empty dir /etc/NetworkManager/dnsmasq.d/
    – HongboZhu
    Nov 30 '15 at 14:41
  • @HongboZhu same here.
    – joar
    Dec 10 '15 at 8:33
  • @HongboZhu My issue was that NM tried to start dnsmasq on 127.0.1.1:53, but that port was already taken by dnsmasq.service. The solution for me was sudo systemctl disable dnsmasq.service
    – joar
    Dec 10 '15 at 9:26
  • @joar Thanks for the info. But it does not help me :(. I still have NM running with ~17% CPU. Disabling WIFI eases CPU usage. Interestingly, re-enable WIFI never works. Restart is required.
    – HongboZhu
    Dec 10 '15 at 10:18
2

I had the similar problem. Another symptom was if I suspended the system, then the DNS failed to work after being awaken from suspend. What helped me was to comment out dnsmasq in /etc/NetworkManager/NetworkManager.conf.

#dns=dnsmasq
2

My issue was that NetworkManager.service tried to start dnsmasq on 127.0.1.1:53, but that port was already taken by dnsmasq.service. The solution for me was sudo systemctl disable dnsmasq.service

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.