1

For accessing the WirelessNetwork (WLAN) in my university, I need to install a certificate on my Nexus 4 with Ubuntu Touch 15.04.

Within the link below my university provides a script for automatic installation of the certificate. But the script works just on my UbuntuDesktop. On my Nexus 4 I get the error 'Permission Denied'Denied' (of course I used sudo)of

Can anybody help me to execute the script or to install theof manually?

Link: http://www.fh-kiel.de/fileadmin/data/Zentrale_IT/WLANeduroam/linux/2014-05-eduroam-linux-Fachhochschule_Kiel-Fachhochschule_Kiel.sh

0

man update-ca-certificates:


update-ca-certificates is a program that updates the directory /etc/ssl/certs to hold SSL certificates and generates certificates.crt, a concatenated single-file list of certificates. It reads the file /etc/ca-certificates.conf. Each line gives a pathname of a CA certificate under /usr/share/ca-certificates that should be trusted. Lines that begin with "#" are comment lines and thus ignored. Lines that begin with "!" are deselected, causing the deactivation of the CA certificate in question. Furthermore all certificates found below /usr/local/share/ca- certificates are also included as implicitly trusted.

From the above, I would infer that the preferred way to get local certificate files into the trusted store is to put them into /usr/local/share/ca-certificates, and then run update-ca-certificates. You do not need to touch /etc/ssl/certs directly.

Naming the certificates with .crt extensions seemed to be required as well.

  • Hey Dai Wei, thank you for your reply! I tried your solution, but it did not work. I found an other solution, see my answer. ;.-) – eDeviser Feb 18 '16 at 11:50
0

Sorry for the big delay. I figured out how to get it work, here is the solution:

On this page, all parameters for WLAN-Setup are listed. If I just connect to the WLAN and select in den Setup-Screen on the UbuntuPhone 'WPA2 Enterprise / AES' as encryption, then all the other parameters can be set. Even the certificate can be selected by the GUI.

0

I just ran into the same issue. On my phone, I couldn't choose the certificate. It gave me the browser and the filemanager as options but, whatever I chose, I could not successfully add the certificate.

What worked for me, though, was getting the python script they make for Uni Siegen for Linux and executing it in the terminal.

In my case, it was over ssh because I like autocomplete but on the phone's Terminal, it will propably work as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.