0

Currently dual-booting Win10/Ubuntu and I'm wanting to auto-mount a shared NTFS drive that I created earlier today. I watched some video tutorial on YouTube explaining how to get the drive details and edit your fstab file, which I've done: Pastebin: Fstab file.

I've also done this without the UUID and using /dev/sda10 instead but no luck, I still get an "Error while mounting" on boot. What am I doing wrong?

  • how about mount /dev/sda10 /mnt, keep the argument minimum to test. – Aizuddin Zali Oct 22 '15 at 14:05
  • Replacing that last line of the fstab? – Alexander Hepburn Oct 22 '15 at 14:11
  • no just go into terminal and mount it manually via that command. if the filesystem is wrong or the module is not loaded, it will throw you some errors. – Aizuddin Zali Oct 22 '15 at 14:12
  • Try removing quotes from UUID entry. UUID=XXXXXXXXXXX /media/kuomi/SHARE ntfs defaults,nls=utf8,umask=000,uid=1000,windows_names 0 0 You did create the mount point /mediai/kuomi/SHARE? Also before rebooting but after editing fstab run this: sudo mount -a if no errors they you know it is correct. – oldfred Oct 22 '15 at 15:07
  • I did try removing the quotes but to no avail. – Alexander Hepburn Oct 22 '15 at 15:25
0

Even dual booting, its unlikely that you have 10 partitions on sda, so /dev/sda10 is probably incorrect. (Because of primary/secondary partitions there could be as little as 7, but my point remains.) I would run

sudo fdisk -l /dev/sda

to try and identify for sure what partition your Windows drive is on. It should have type NTFS.

Another option if you have a full desktop installed, would be to browse to the drive using the file manager. This will automatically mount it under /media/$yourusername. You can then use the df command to see what partition it mounted and use that in your fstab instead of /dev/sda10

| improve this answer | |
  • After double checking, it is definitely sda10. I have ten partitions on sda, about 5x Win ones, this SHARE partition, 3 ubuntu and a lenovo partition. – Alexander Hepburn Oct 22 '15 at 15:27
  • I also noticed under your pastebin fstab that your fs type is fuseblk. This is what the kernel reports for a mounted NTFS partition, but you should try type ntfs in your fstab. Last I knew ubuntu still uses NTFS-3G – edithink Oct 23 '15 at 16:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.