I've run distro upgrade from 14.04 to 15.10 with the release image. I chose "erase the disk and install Ubuntu" installation. No errors during installation and I'm able to login in normally.

Eventually I will get this message:

fsck from util-linux 2.26.2
/dev/mapper/ubuntu--vg-root: clean 194728/13557760 files, 947832/54231040 blocks

It then dumps me back to the login page. Cycle repeats and repeats, but never boots me into the desktop.

When I boot into recovery mode, I can run fsck from there, and it gives me the same clean message. However, it does give me the message:

 "Error getting authority: Error initializing authority: Could not connect: No such file or directory (g-io-error-quark, 1)

Any ideas what's going on? I've re-run install a few times and get the same thing every time.

  • What you say is not an "upgrade" but a re-install. You can upgrade from 15.04 to 15.10. From what you say you re-installed.Something different with different related things to check ;) – Rinzwind Oct 22 '15 at 13:44
  • 1
    same error: askubuntu.com/questions/631362/… and askubuntu.com/questions/614198/… see if any of these 2 can help you fix this. – Rinzwind Oct 22 '15 at 13:45
  • It's odd. I updated packages, and now I'm in the desktop. – Elvisisdead Oct 22 '15 at 13:46
  • Glad to hear it fixed itself :D I wish all problems would fix them self :P – Rinzwind Oct 22 '15 at 13:50

I'll be honest, and I have no idea why this worked. I booted into recovery mode. Ran fsck. Then fixed broken packages (which downloaded 3 new packages). Resumed boot into the new image. It threw one error, uploaded the details and it's all good now.


The fsck message is probably a red herring. You are probably just seeing typical boot noise from the console because there is an issue with your display drivers preventing the X server from starting a display manager.

Glad to hear you got it fixed though. If I had to guess, one of the broken/outdated packages was a binary display driver.


I had same trouble after uninstalling a kubuntu-desktop on my ubuntu 15.10 laptop. try reinstall lightdm.

sudo apt-get install --reinstall lightdm
  • I think --reinstall lightdm is not the solution , there may be another reasons. – Avani badheka Oct 3 '16 at 8:53

Not the answer you're looking for? Browse other questions tagged or ask your own question.