5

I can't use Ubuntu the normal way. Each time I boot it I need to set radeon to 0, or use nomodeset. I don't have the fglrx drivers (the Trusty kernel and X.org does not support it), only the open ones. Each time I boot as normal, I get the screen turned off, nothing works. Tried to use everything, editing GRUB (before you ask, yes, I sudo update-grub'd it), adding a xorg.conf file (but it gets renamed each boot)...

Useful info: graphic card is ATI Radeon HD 4670. I don't want to use the nomodeset option, just to get my graphics to work.

If you need some log info or so, I'll attach it.

  • I found out that Wayland does work out of the box (tried Ubuntu 17.10) in this computer. Radeon included. So the problem is X-related. – Suzamax Nov 12 '17 at 22:17
3

this Question ist older, but I found a some how working solution I could not find for this context in any other answers to this problem.

I expirienced an similar behavior when booting up Kubuntu 16.10 on an iMac (late 2009) since a few weeks: The system is running but the backlight is switched off some how at that moment when the framebuffer driver is activated.

It started after using the external displayport or an kubuntu-update I can not tell which. The nomodeset/...modeset=0 thing somehow works but then the radeon driver isn't loaded anymore and things that benifit a lot from hardware accelleration like googelmaps are not usable or only usable with pain.

At the moment I only have a solution for X:

SSH ssh username@yourImacIP -XC (-XC means: compressed with X-forwarding) to the iMac and run:

xrandr -d :0 --output eDP --crtc 1 --brightness 0.8

This how ever only works if I start the normal X-Displaymanager/Desktop-environment (in my case KDE) on the iMac. So i have to assume that the correct useraccount is allready selected and I only have to type in the password blindly. Of course xrandr must be installed.

If I run the same command again - the screen turns black and if again the screens turns on again. So the logic of the command as I understand it (changing the brightness to a value between 0 and 1) is not working correct.

If anyone has a solution for the framebuffer-bootup not turning off the monitor-backlight I would appreciate it.

Update:

After the upgrade to kubuntu 17.10 the radeon driver didn't work at all in this setup.

But (current) happy end: with the latest updates (around middle of November) of the current Version of Kubuntu (17.10) the described procedures above seems not necessary anymore! The Display comes up without any hassle and I can use the console again. Thank the almighty kubuntu or radeon-driver developers!

Still not working is my external display port :( The hardware seems to be gone...

If you still need the procedure above - attaching the line

xrandr -d :0 --output eDP --crtc 1 --brightness 0.7

to your local (in your user directory) *.xinit, .xinitrc or .xsessionrc* (whatever works) eases your live. You only have to authenticate blindly. A remote ssh is not necessary anymore.

| improve this answer | |
  • 1
    Oh. My. $Deity. Thank you so much for this. This needs to be published much more than just here. – UrkoM Nov 10 '17 at 13:50
  • I tried this some more, and it seems the key is "--crtc 1". When you run "xrandr --output eDP --crtc 1" it toggles the display on and off. If you just run "xrandr --output eDP --brightness 0.4" (or any other number between 0 and 1) after you turn on the display with the first command, the brightness adjustment works. – UrkoM Nov 25 '17 at 9:00
1

There's no other chance than "deactivating the graphics card" as AMD Catalyst does not support Radeon 4000 series anymore and the radeon open source drivers are not working without issues on your AMD Radeon 4670 GPU. For a permanent workaround solution follow the instructions ...

Open a terminal and execute:

sudo apt-get install gksu  

Then execute:

gksudo gedit /etc/default/grub  

Add radeon.modeset=0 to this line : GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

that it reads : GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.modeset=0"

Then execute :

sudo update-grub
| improve this answer | |
  • That's what I've been doing. Something weird is that Ubuntu 15.04 from USB boots perfectly with drivers, but that's strange, booting normally (not from USB) gives me the black screen. What I want is to get the graphic to work, not to disable it. – Suzamax Oct 22 '15 at 11:03
  • @Suzamax : As it seems you unfortunately have to work with the integrated intel graphics - this is why most users choose NVIDIA chips over AMD ones - sorry for you ... but intel graphics aren't that bad - so consider to just take the optional workaround ! :) – cl-netbox Oct 22 '15 at 11:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.