Of course, we first have the issue that Dell decided that not mentioning the model number on their laptops was much more user friendly. It says "Inspiron 15, 5000 series" on some kind of sticker on the left below the keyboard.

So, as an improvement to their previous models, Dell has added a keyboard combination to switch off the wifi (who has ever asked for that?). By default, the wifi is switched off (Duh). You have to press that keyboard combination first, before wifi will be activated. Unlike what they may think, what they came up with is not a feature. It is a bug.

From there, wifi will only work for some wifi networks. Everybody else will be able to connect on the fly, while everybody using the Dell/Ubuntu combinations will be out of luck. It is difficult to say why exactly Dell/Ubuntu wifi works with some networks and not with others; but nobody else besides Dell/Ubuntu users seems to be complaining.

If I disable and re-enable the wifi in the unnamed program in the top menu bar, the wifi networks will disappear, never to reappear again. Gone. Bye bye. That is another bug.

Every year the combo Dell/Ubuntu seems to be getting worse and worse. The accumulation of bad ideas just does not seem to stop! Let's go back to Ubuntu 8.10 or 9.04 and start all over again. Seriously, I am amazed with the spectacular and growing crapzilla that they came up with after that!

My question: Since I don't dare to upgrade for fear that other things will break down too, how do I fix the wifi in Ubuntu 15.04?

EDIT: further investigation

$ lspci -nnk | grep Net -A2
06:00.0 Network controller [0280]: Intel Corporation Wireless 3160 [8086:08b3] (rev 83)
    Subsystem: Intel Corporation Dual Band Wireless AC 3160 [8086:8470]
    Kernel driver in use: iwlwifi

And:

$ sudo lspci -vvnn | grep -A 9 Network
06:00.0 Network controller [0280]: Intel Corporation Wireless 3160 [8086:08b3] (rev 83)
    Subsystem: Intel Corporation Dual Band Wireless AC 3160 [8086:8470]
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-  Stepping- SERR- FastB2B- DisINTx+
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 49
    Region 0: Memory at f7100000 (64-bit, non-prefetchable) [size=8K]
    Capabilities: [c8] Power Management version 3
        Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
        Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
  • Please update your question with lspci -nnk | grep Net -A2 command output from a terminal (Ctrl + Alt + t). – P.-H. Lin Oct 22 '15 at 6:27
  • Include what card you are using with lspci -vvnn | grep -A 9 Network – pzkpfw Oct 22 '15 at 6:28
  • this is why I prefer LTS builds... less bugs :P (Ubuntu 14.04.4 LTS) – wagyourtail Apr 20 '16 at 19:10

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.