7

I am on the Thinkpad T450s. I'm on Ubuntu version 15.10 and kernel version 3.19.0-15-generic.

Everything works great except the following issue. Each time I re-open the lid of the laptop after it has been shut (i.e. after it resumes from sleep mode), Ubuntu is completely unusable. Text rarely renders, most UI elements are missing the text, and even if any text is present, it's usually garbled with strange characters. I'm not even able to type in the terminal. The only solution has been to restart which fixes everything, only for me to shut the lid again. This happens reliably, every time the lid is shut. I use two different window managers, the default Unity (Desktop Environment) and also Awesome-WM. The error happens with both these WMs. See the two screenshots below which show gmail.com and google.com in firefox after this issue.

Any ideas how I should go about debugging this issue?

Here is the output from lshw -c video

  description: VGA compatible controller
   product: Broadwell-U Integrated Graphics
   vendor: Intel Corporation
   physical id: 2
   bus info: pci@0000:00:02.0
   version: 09
   width: 64 bits
   clock: 33MHz
   capabilities: vga_controller bus_master cap_list rom
   configuration: driver=i915 latency=0
   resources: irq:47 memory:e0000000-e0ffffff memory:d0000000-dfffffff ioport:3000(size=64)

  • Does it get fixed if you just log out and in again? Or if you drop to a tty with Ctrl+Alt+F1 and back to X with Ctrl+F7? How about if you re-launch the window manager? I don't know if unity or awm have this feature but many have a --replace flag. On cinnamon, for example, I can run cinnamon --replace & to restart it. – terdon Oct 21 '15 at 23:54
  • Just tried this also. Doesnt help :( I tried both the Ctrl_Alt_F1 and also restarting awesome (Mod4+shift+r), but the issue recurred. See the screenshots I've linked to above. – figuringout Oct 22 '15 at 0:14
  • I have the same issue on 16.04 LTS (4.4.0-45-generic) and Thinkpad T430. Text is missing after suspend from all menus, Nautilus and terminal, but not in Firefox. For me this happens only after some suspends, and I can type and have full control except I can't see the output. Would be grateful for any tips how to debug this. – Valentas Nov 4 '16 at 13:57
  • @Valentas Did you ever fix your version of the problem? I have the same one: text missing from menus/terminals but fine in Firefox, only after some suspends. kernel 4.4.0-75-generic. – weronika Apr 30 '17 at 14:30
  • @Valentas, @weronika : See askubuntu.com/a/925855/8822 which links to bug Bug #1573959 and suggests upgrading the kernel from 4.4 to 4.8. (sudo apt install linux-generic-hwe-16.04) – mivk Jun 15 '17 at 20:27
2

You are probably experiencing a bug related to framebuffer memory corruption due to improperly marking particular portions for saving/restoring.

See this discussion. Sadly the best resolution is to try a different kernel.

I have not experienced it on 4.2, but it's a serious bug on 4.4.

Maybe try a stable kernel. (Such as the 3.2 for Debian, which is the base for precise: http://kernel.ubuntu.com/~kernel-ppa/mainline/)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.