10
The following packages have unmet dependencies:
 vlc : Depends: vlc-nox (= 2.1.4+git20150226+r54594+19+11~ubuntu14.04.1) but it is not going to be installed
       Depends: libsdl-image1.2 (>= 1.2.10) but it is not installable
       Depends: libtar0 but it is not installable
       Depends: libva-x11-1 (> 1.3.0~) but 1.0.15-4 is to be installed
       Depends: libva1 (> 1.3.0~) but 1.0.15-4 is to be installed
       Depends: libvlccore7 (>= 2.1.0) but it is not going to be installed
       Recommends: vlc-plugin-notify (= 2.1.4+git20150226+r54594+19+11~ubuntu14.04.1) but it is not going to be installed
       Recommends: vlc-plugin-pulse (= 2.1.4+git20150226+r54594+19+11~ubuntu14.04.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I tried

  1. sudo apt-get install -f
  2. sudo apt-get update
  3. sudo apt-get upgrade
  4. sudo apt-get purge vlc vlc-nox libsdl-image1.2 libtar0 libva-x11-1 libva1 libvlccore7 vlc-plugin-notify vlc-plugin-pulse

But the error remains. VLC is not the only thing. many other packages I try to install gave me similar dependency errors which I finally gave up installing.

I have been using Ubuntu for a while now. I just don't understand why this happens every now and then. Please help ...

EDIT:

Output of apt-cache policy vlc vlc-nox libsdl-image1.2 libtar0 libva-x11-1 libva1 libvlccore7

vlc:
  Installed: (none)
  Candidate: 2.1.4+git20150226+r54594+19+11~ubuntu14.04.1
  Version table:
     2.1.4+git20150226+r54594+19+11~ubuntu14.04.1 0
        500 http://ppa.launchpad.net/videolan/stable-daily/ubuntu/ trusty/main i386 Packages
vlc-nox:
  Installed: (none)
  Candidate: 2.1.4+git20150226+r54594+19+11~ubuntu14.04.1
  Version table:
     2.1.4+git20150226+r54594+19+11~ubuntu14.04.1 0
        500 http://ppa.launchpad.net/videolan/stable-daily/ubuntu/ trusty/main i386 Packages
libsdl-image1.2:
  Installed: (none)
  Candidate: (none)
  Version table:
libtar0:
  Installed: (none)
  Candidate: (none)
  Version table:
libva-x11-1:
  Installed: (none)
  Candidate: (none)
  Version table:
libva1:
  Installed: (none)
  Candidate: (none)
  Version table:
libvlccore7:
  Installed: (none)
  Candidate: 2.1.4+git20150226+r54594+19+11~ubuntu14.04.1
  Version table:
     2.1.4+git20150226+r54594+19+11~ubuntu14.04.1 0
        500 http://ppa.launchpad.net/videolan/stable-daily/ubuntu/ trusty/main i386 Packages
0
12

As you can see in the output of apt-cache policy … there are some packages without an installation candidate and that should not be the case. Therefore a quick search here shows, that all packages are available in the universe repository, e.g. for the package libsdl-image1.2.

enter image description here

Add the repository:

sudo apt-add-repository universe
sudo apt-get update
sudo apt-get install vlc
0

Not the answer you're looking for? Browse other questions tagged or ask your own question.