1
  • This is an urgent case because I am no longer boot into any OS in my laptop now, I am using my phone to post the question.

  • I am using dual boot on my laptop- Ubuntu 14.04 LTS 64 bit- Windows 8 and Windows 7 32 bit (When I choose to boot this option it will open the Windows chosen )

  • The problem happens today, I can't boot into the Windows. I tried to use boot-repair from Ubuntu to fix this issue but it didn't work. So I tried with the option to upgrade the GRUB (I think it is the source of problem). I follow the step provided by boot-repair, everything going well except when finished it prompt an error about saving file, I didn't notice it and I still restarted it(it can't make the paste link either).

  • This is the paste link of last good configuration that I have: Paste Ubuntu

  • Currently, when I power on my laptop, it just exist black page, I managed to get in the grub-rescue command-line and get the error /boot/grub/i386-pc/normal.mod not found. I followed the instruction in this answer but it didn't work either:Stack Answer When I type ls command, this is the list of available partition:

File system is unknown

  • (hd0)
  • (hd1)
  • (hd1,msdos6)
  • (hd1,msdos7)

File system is ntfs

  • (hd0,msdos1)
  • (hd1,msdos5)
  • (hd1,msdos3)
  • (hd1,msdos2)
  • (hd1,msdos1)

I tried to search through every partitions to find the normal.mod but I couldn't find it:

ls (hd0,msdos1)/boot/grub/i386-pc/normal.mod

The command echo and search.files is not available for me now.

When I type the command set:

cmdpath=(hd0)
prefix=(hd0,msdos1)/boot/grub
root=hd0,msdos1

I hope I gave enough information, please tell me what I need to do.

P/s: Because I am using phone to post so any edit is very appreciated

Edit 1: Update 1:

I managed to escape the grub rescue to enter the normal grub, I found only grub_old not grub in (hd0,msdos1) and I tried to run normal.mod from here and it worked.

Now, I am trying to find the linux kernel image to boot from this but I couldn't find it elsewhere, should I make another Ubuntu 14.04 usb stick to let it find the iso file inside that usb?

  • Better to see link from last Boot-Repair. But your install is in sda6, so if your ls shows that as hd1, then your system is promoting flash drive to hd0 and you want to manually boot hd1,6. – oldfred Oct 21 '15 at 15:38
2

I found a quite simple solution, write out here for anyone who need it:

  • You should have a Ubuntu in your CD or in your USB stick, prepare it.
  • Try to boot into this Ubuntu through boot option(In my case, I pressed F2 when I powered on my laptop, it is usually, F8, F10 or F12)
  • It will load Ubuntu components and will ask you want to Try or Install, choose Try it because you want to fix, not install a new one.
  • When get inside, try to find where GRUB is, install a new one through some command like:

    sudo grub-install

If everything worked well, you can boot normally in next reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.