11

I have a problem with my bluetooth adapter. Can't turn it on, and i followed some tutorials to fix that, but with no luck. It seems to be soft blocked, I run the command to soft unblock, the icon in taskbar goes white for a 0.5 second and then is switched back. how can i unblock this? here is the output of console when I run rfkill list all :

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: hp-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: hp-bluetooth: Bluetooth
    Soft blocked: yes
    Hard blocked: no

I used sudo rfkill unblock bluetooth to unblock bluetooth. Thanks.

1
  • Please edit your question and add output of lspci -knn | grep Net -A2; lsusb terminal command. – Pilot6 Oct 21 '15 at 14:04
11

If the unblock command doesn't work, try another two commands (which will ask for password):

rfkill unblock bluetooth
systemctl enable bluetooth.service
systemctl start bluetooth.service
0
1

I have been facing this same issue since the last 1 week; I remember it well because I regularly connect my bluetooth headphones/earphones with the system for media consumption.

The issue started occurring after I performed my weekly system update.

The OS I am using right now is Pop-OS 20.04 which is a derivative of ubuntu 20.04.

I followed the steps specified in the answer by Lesego above with some changes :-

First, lets list all the devices being controlled by rfkill :-

$ sudo rfkill list all
0: phy0: Wireless LAN
       Soft blocked: no
       Hard blocked: no
1: hci0: Bluetooth
       Soft blocked: yes
       Hard blocked: no

The output shows that bluetooth has been soft blocked.

Then I run the command to remove the soft block from Bluetooth device

sudo rfkill unblock bluetooth

Next, let's again check the list of all the devices being controlled by rfkill :-

$ sudo rfkill list all
0: phy0: Wireless LAN
       Soft blocked: no
       Hard blocked: no
1: hci0: Bluetooth
       Soft blocked: no
       Hard blocked: no

Now, if I check the status of bluetooth service to confirm whether the service is enabled to start on boot or not, the output shows that the service is enabled as well as "active (running)" :-

$ sudo systemctl status bluetooth.service
 ● bluetooth.service - Bluetooth service
      Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
      Active: active (running) since Sat 2021-04-03 15:10:26 IST; 1h 13min ago
        Docs: man:bluetoothd(8)
        Main PID: 1105 (bluetoothd)
        Status: "Running"
        Tasks: 1 (limit: 18579)
        Memory: 1.7M
        CGroup: /system.slice/bluetooth.service
                └─1105 /usr/lib/bluetooth/bluetoothd
 
Apr 03 15:10:26 pop-os systemd[1]: Starting Bluetooth service...
Apr 03 15:10:26 pop-os bluetoothd[1105]: Bluetooth daemon 5.53
Apr 03 15:10:26 pop-os systemd[1]: Started Bluetooth service.
Apr 03 15:10:26 pop-os bluetoothd[1105]: Starting SDP server
Apr 03 15:10:27 pop-os bluetoothd[1105]: Bluetooth management interface 1.19 initialized
Apr 03 15:10:38 pop-os bluetoothd[1105]: Endpoint registered: sender=:1.75 path=/MediaEndpoint/A2DPSink/sbc
Apr 03 15:10:38 pop-os bluetoothd[1105]: Endpoint registered: sender=:1.75 path=/MediaEndpoint/A2DPSource/sbc
Apr 03 15:10:42 pop-os bluetoothd[1105]: Failed to set mode: Blocked through rfkill (0x12)

So, instead of running the enable and then the start command for bluetooth.service; I run :-

sudo systemctl restart bluetooth.service

After doing the following steps;

  • The bluetooth service starts working and I can connect my bluetooth devices with the system till I click on "Turn Off" in the bluetooth settings option.

  • And then again if I click on "Turn On" in the bluetooth settings option that does not work.

  • I need to again do the above specified steps to make the bluetooth service working again.

The steps shared also do not persist through system reboots.

What I was able to understand from multiple community forums where similar issues were discussed is that this could be related to a faulty driver or a kernel update gone wrong and I think that could be the case because I started experiencing this issue the day after I did a system packages update.

So, one thing seems to be confirmed that this can/will be fixed via future system package updates, I just need to wait for the same and follow these specified steps till the issue gets resolved on its own via future provided updates.

0
0

Check for hci0. Run this command(1),

hciconfig dev

It is likely that hci0 is down in this case. If it is, run this command(2) below to reset hci0

sudo hciconfig hci0 reset

Run (1) again. hci0 should be up and running. If it's still down, and the error 'Can't init device hci0: Operation not possible due to RF-kill (132)' is thrown, run the command (3) rfkill. If bluetooth is soft-blocked, unblock it by running(4)

sudo rfkill unblock bluetooth

and try (2) again. This should solve the issue. Although, hci0 may have to be reset after every reboot. I still face this issue where bluetooth goes down by itself everytime system is suspended.

0

I was fighting with this for some time too, using ubuntu budgie 21.04. The normal controls were doing nothing, then when run systemctl status bluetooth I was reading:

jun 11 11:43:54 mypc bluetoothd[837]: Bluetooth management interface 1.19 initialized
jun 11 11:43:53 mypc systemd[1]: Started Bluetooth service.
jun 11 11:43:56 mypc bluetoothd[837]: Failed to set mode: Blocked through rfkill (0x12)
jun 11 11:44:12 mypc bluetoothd[837]: Endpoint registered: sender=:1.40 path=/MediaEndpoint/A2DPSink/sbc
jun 11 11:44:12 mypc bluetoothd[837]: Endpoint registered: sender=:1.40 path=/MediaEndpoint/A2DPSource/sbc
jun 11 11:45:19 mypc bluetoothd[837]: Endpoint unregistered: sender=:1.40 path=/MediaEndpoint/A2DPSink/sbc
jun 11 11:45:19 mypc bluetoothd[837]: Endpoint unregistered: sender=:1.40 path=/MediaEndpoint/A2DPSource/sbc
jun 11 11:45:20 mypc bluetoothd[837]: Endpoint registered: sender=:1.52 path=/MediaEndpoint/A2DPSink/sbc
jun 11 11:45:20 mypc bluetoothd[837]: Endpoint registered: sender=:1.52 path=/MediaEndpoint/A2DPSource/sbc
jun 11 11:45:35 mypc bluetoothd[837]: Failed to set mode: Blocked through rfkill (0x12)

But trying changing the status using something like rfkill unblock bluetooth wasn't helping. Neither rebooting.

The only thing that solved the problem was running sudo systemctl restart bluetooth.service.

I think the cause of it was something quite trivial like putting my computer in sleep mode and after that, turning off the bluetooth speaker I was using and never unpair it or properly turning off the device from the computer.

So this is my 2 cents. Try to restart the bluetooth service.

New contributor
Bruno Vasco is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.