1

I'm trying to change partition sizes on a Ubuntu 14 desktop by running GParted from a USB stick. However, the partition that I want to shrink won't go below its current size. The entire drive is practically empty.

I checked related posts, but couldn't find an answer to my situation. I do understand that the key icon next to partition indicates that changes can't be made, but how exactly to fix that? Thanks!

enter image description here

====================== UPDATE: After applying GUI tool: system-config-lvm, I was able to start resizing, but GParted runs into an error.

Some free space available: enter image description here

Resize settings: enter image description here

Error: enter image description here

  • Have a look at this post, which explains about how to resize LVM partition. Then, leave a comment or edit your question to update whether you managed to resolved or not. – clearkimura Oct 21 '15 at 6:16
1

I can't explain much for LVM partition, but here's the generic steps.

I do understand that the key icon next to partition indicates that changes can't be made, but how exactly to fix that?

First, you need to unmount the LVM partition.

  1. In GParted, select or highlight the row containing /dev/sda5
  2. In the menubar, select Partition > Deactivate

GParted will rescan the partitions and the key icon will disappear.

Next, to shrink the LVM partition.

  1. In GParted, select the same row i.e. /dev/sda5 again
  2. In the menubar, select Partition > Resize/Move

A small dialog will appear, where you can resize the partition by dragging the left/right arrow in the top rectangular box representing the partition. Or, you can specify the partition size in mebibytes (MiB) by using the spinner (up-down control).

Additional steps may be required, which I don't have experience.

  • Thank you for your advice. When I highlight /dev/sda5, there is no option to "Unmount". There is however an option to "Deactivate". It does remove the key icons, but the partition still can't be resized. – user1566515 Oct 21 '15 at 6:10
  • Ah, I think it is because the partition is an LVM partition. Not a typical one. – clearkimura Oct 21 '15 at 6:14
  • Thanks again for the suggestion. I used GUI tool: system-config-lvm from the post that you recommended. It seemed to work in freeing up some space on the LVM partition. GParted is now able to start re-sizing, but shows an error. I'm adding screenshots to the question. – user1566515 Oct 21 '15 at 7:00
0

I had a similar problem using Gparted to resize of the main partition on an xp pc. A yellow warning by the ntsf partition indicated that ntsf files could not be read. Searched in various linux forums until I found this http://ubuntuforums.org/showthread.php?t=1515568&page=2 The solution apparently was to disable windows XP virtual memory. In another post, I read some windows 7 users had also disabled hybernation on their computers. So I did both things: disabled virtual memory and disabled hybernation. Then I rebooted, opened Gparted (with a live mint usb), and I was able to resize the ntsf partition. When I finished installing Mint, I went back to XP and enabled both virtual memory and hybernation

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.