12

When I open the Unity Dash from the launcher, the Dash takes up the whole screen and doesn't give me the ability to resize it. This makes it impossible to see my desktop and drag and drop icons to it in order to create shortcuts. I've seen some screen where the dash has maximize and minimize buttons, but I do not have anything like that on my 11.10 install.

Unity Dash - No Resize option

9

For Ubuntu 11.10

The solution depends on whether you are using the standard or 2D version of Ubuntu, which depends on your graphics card. (See: Am I using Unity or Unity 2D? )

Resizing the Dash in the standard Ubuntu

When opening the Ubuntu Dash, you should see three "window buttons" in the upper-left. Click the maximize button (the square) to switch between fullscreen and windowed mode.

Resizing the Dash in Ubuntu 2D

Install and launch Dconf Editor (Software Center). Once it's open, navigate to the desktop > unity section in the left pane. You will see a form-factor option, which if set to 'Netbook' will made the Dash fullscreen, and if set to 'Desktop' will make the Dash windowed.

picture of dconf

What about drag-resizing the Dash, like a Window?

There are many unconfigurable parts of Unity, and this is one of them. The Dash has two modes (fullscreen and windowed) and you can switch between them using the methods above. You can't drag-resize the Dash.

In defense of Unity's design, though, there's no reason you'd want to resize the Unity Dash to arbitrary dimensions on the fly. You don't "drag and drop icons [from the desktop to the Dash] in order to create shortcuts", as the question asker mentioned; that's what the launcher is for. The Dash is designed to be the sole focus on your desktop when you use it.

2

Type: dconf write /com/canonical/unity/form-factor "'Desktop'" This will set in terminal the dconf property to Desktop (same as in gui - see answer below). It works on 16.10 and surely also on 16.4. I wouldn't know for older versions. By "works" i mean that Dash is set to smaller size - you can't actually resize it (option removed from unity) but at least it does not cover all the screen.

  • @WinEunuuchs2Unix I can't test this command at the moment, but to me this answer looks valid. - However, Beernarrd, you should add some more detail and explain what your command is doing and why it solves the problem. – Byte Commander Dec 21 '16 at 13:22
  • Could you expand this answer a bit to include which versions of Ubuntu you tested it on? This will help others find answers that work for them. Thank you! – Elder Geek Dec 21 '16 at 14:40
  • @ByteCommander I believe you are right. I've deleted the review comment. Bernard: Could you expanded your answer as ByteCommander and ElderGeek requested? Thanks. – WinEunuuchs2Unix Dec 21 '16 at 14:47
  • hope the additional info is ok also for version 11. cannot check it. – Beernarrd Dec 22 '16 at 18:23
1

You can install dconf-editor from Software Center start it, and go to

desktop -> unity

and change the form-factor from Netbook to Desktop.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.