2

Alright so I've looked around on askubuntu and a few other forums but I can't seem to find the answer I need to get the problem resolved. I am running Ubuntu 14.04 and only recently installed it. I've loved it for the past couple of days, but now my software center will NOT open. I've already tried updating everything, I've uninstalled and reinstalled software center, I've run it from the terminal, I've done everything I could possibly find in the forums about this issue. None of it has worked. This is the text I get when I run software center in the terminal:

~$ software-center
2015-10-20 15:10:36,406 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'

2015-10-20 15:10:39,786 - softwarecenter.region - WARNING - failed to use geoclue: 'org.freedesktop.Geoclue.Error.notAvailable: Geoclue master client has no usable Address providers'

2015-10-20 15:10:40,554 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file

2015-10-20 15:10:40,573 - softwarecenter.plugin - INFO - activating plugin '<module 'webapps_activation' from '/usr/share/software-center/softwarecenter/plugins/webapps_activation.pyc'>'

2015-10-20 15:10:40,739 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()

2015-10-20 15:10:41,602 - softwarecenter.backend.reviews - WARNING - error creating bsddb: '(22, 'Invalid argument -- BDB0054 illegal flag combination specified to DB_ENV->open')' (corrupted?)

2015-10-20 15:10:41,603 - softwarecenter.backend.reviews - ERROR - trying to repair DB failed
Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/backend/reviews/__init__.py", line 358, in _save_review_stats_cache_blocking
    self._dump_bsddbm_for_unity(outfile, outdir)
  File "/usr/share/software-center/softwarecenter/backend/reviews/__init__.py", line 377, in _dump_bsddbm_for_unity
0600)
DBInvalidArgError: (22, 'Invalid argument -- BDB0054 illegal flag combination specified to DB_ENV->open')

/usr/lib/python2.7/dist-packages/gi/overrides/GLib.py:535: Warning: Source ID 76 was not found when attempting to remove it
  return super(MainContext, self).iteration(may_block)

/usr/lib/python2.7/dist-packages/gi/overrides/GLib.py:535: Warning: Source ID 20 was not found when attempting to remove it
  return super(MainContext, self).iteration(may_block)
Bus error (core dumped)
  • 1
    Try sudo /usr/share/software-center/update-software-center and give me a ping in the comments with @A.B. – A.B. Oct 20 '15 at 19:53
  • @A.B. I inputted the line you said to and the result was as follows: >Updating software catalog...this may take a moment. >INFO:softwarecenter.db.pkginfo_impl.aptcache:aptcache.open() >Software catalog update was successful. After which I once again attempted to start the software center and it crashed with the same messages. Thank you for the reply, any other ideas? – Dillon Scott Oct 21 '15 at 2:08
  • Open a terminal and give me the output of sudo apt-get install -f – A.B. Oct 21 '15 at 5:59
  • @A.B. Here is the output for the command: >Reading package lists... Done Building dependency tree Reading state information... Done 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. – Dillon Scott Oct 21 '15 at 7:28
  • Had the same problem. Used this fix and it worked for me. (askubuntu.com/a/781820/640078) – Samuel Waithaka Jan 10 '17 at 8:41
2

Uninstalling won't make a difference. You need to purge the software-center. Run the following commands and please post any errors:

sudo apt-get purge software-center software-center-aptdaemon-plugins

Then, reinstall it:

sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install software-center software-center-aptdaemon-plugins

EDIT

It looks like it could be hardware related as the only thing out of the ordinary here is the bus error. You could try running the following command:

sudo rm /var/cache/apt/*.bin

source

| improve this answer | |
  • I had already tried purging it I apologize for leaving it out of the list of troubleshooting I've already done. Just to be safe, I went ahead and ran the commands you listed and got the exact same line of errors I've been getting the entire time. – Dillon Scott Oct 21 '15 at 4:33
  • @DillonScott I have updated the answer – mchid Oct 21 '15 at 6:31
  • What would be the issue with my hardware? I can't think of anything that could be wrong with anything in my system other than the hard drive and reformatted it before installing Ubuntu. I ran the other command and seemingly nothing happened. What were the results I should have expected? – Dillon Scott Oct 21 '15 at 7:33
  • @DillonScott For hardware, it could be RAM but it could be a software issue as well. You should have not expected a Bus error. What does your swappiness setup look like? – mchid Oct 21 '15 at 7:58
  • Swappiness is set to 60. I haven't had ANY trouble out of any other application on this machine though so I don't really understand how RAM would be the problem with one application and exclusively that application. Unless of course the software-center uses up absolutely massive amounts of RAM. The machine I'm using has 4 Gb if that helps. – Dillon Scott Oct 21 '15 at 16:26
0

I could fix it by following this answer. Maybe an admin could mark this question as repeated

sudo apt-get upgrade gnome-software 
| improve this answer | |
0

For me - suffering from the mysterious bus error message on any attempt to use either Software Center or Synaptic or apt-get from the terminal - I had to do first

sudo rm /var/cache/apt/*.bin

and then

sudo apt-get upgrade gnome-software

After which, so far so good again.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.