43

Gnome-shell seems to like to leave one monitor as "fixed" when you switch workspaces.

Additionally, there is no preview in the Activities view of my secondary monitor.

Also, on the second monitor, where there should be either empty desktop space, or a copy of the panel, I just have a white bar.

How can I get gnome-shell to treat my secondary monitor like the primary one?

0
17

14.04

In later versions of Gnome, you have to open gnome-tweak-tool and, under "Workspaces", change the "Workspaces only on primary display" setting.

6
  • I use 14.04 with gnome-shell from standard repositories and this does not work for me. The switch does not change anything. Sep 9 '15 at 12:39
  • Don't have enought reputation to comment fossfreedom answer and Ted Barth comment, so I add a new answer: on 14.04, this trick works, but you need to reboot to apply changes.
    – user473799
    Nov 19 '15 at 10:44
  • there is no "Workspaces only on primary display" menu item in Ubuntu 14.04 Jan 31 '16 at 4:28
  • this need to be done again after you upgrade to 16.04 ;) Aug 21 '16 at 14:42
  • 1
    This only solves the first problem, but not the second one. See askubuntu.com/a/1125322/16985 Mar 13 '19 at 13:40
14

I could not find the /desktop/gnome/shell/windows key mentioned by Martin, but the source he's quoting says to run:

$ gsettings set org.gnome.shell.overrides workspaces-only-on-primary false

This fixed it instantly for me. Thanks, gregcor (the source).

5
13

Regarding the fixed second monitor, there's an easy way to fix that as I have just found out. If I may quote:

  1. Download gconf-editor – this is probably available in your distribution’s package manager.
  2. Start gconf-editor – the “Run Command” menu is still available in GNOME 3 by pressing Alt-F2.
  3. In the tree on the left, navigate to /desktop/gnome/shell/windows
  4. UNCHECK the box next to workspaces_only_on_primary

Source: http://gregcor.com/2011/05/07/fix-dual-monitors-in-gnome-3-aka-my-workspaces-are-broken/

4
  • 1
    Thanks for that! That solves the problem in terms of switching workspace with the keyboard, but in the activities view the second monitor shows windows from the second monitor of all workspaces. Hopefully they work on multi monitor support in the future.
    – Alex
    Nov 5 '11 at 1:58
  • 1
    See other answers ... this solution is depreciated. Jul 14 '17 at 1:17
  • Confirmed this is deprecated in 18.04.1 LTS. See askubuntu.com/a/1086531/340383
    – bgoodr
    Oct 23 '18 at 20:53
  • @Alex for the Activities problem, see askubuntu.com/a/1125322/16985 Mar 13 '19 at 13:41
12

Setting workspaces-only-on-primary false (using gsetting, gconftool, GNOME Tweak or whatever – see all other answers) only solves the first problem:

Gnome-shell seems to like to leave one monitor as "fixed" when you switch workspaces.

For the second problem

Additionally, there is no preview in the Activities view of my secondary monitor.

there is a GNOME extension called Multi Monitors Add-On that Just Works™. (See also How do I install and manage GNOME Shell extensions?)

2
  • 1
    This solution provides the final piece of the puzzle. The other answers all address having workspace behaviour on secondary monitors, but not having the preview of both in activities view. Thanks for solving my 7 year old problem. :)
    – Alex
    Mar 15 '19 at 1:16
  • 1
    glad I could help :) Mar 18 '19 at 10:21
4

You can do this by installing GNOME Tweaks from Ubuntu Software. After installation, it shows in apps drawer as Tweaks. The package name is actually called gnome-tweak-tool.

The option you are looking for is located in the Workspaces tab, and it is called Workspaces span displays.

5
  • I can't find Tweaks. Is there a certain repository I need to have? Oct 3 '17 at 7:43
  • No special repository, it is in universe. Application name is GNOME Tweaks in Ubuntu Software. I'll update the answer to reflect this.
    – philsf
    Oct 3 '17 at 17:11
  • use sudo apt install gnome-tweak-tool. You as well should be able to find it with this name in the Software-Center.
    – Videonauth
    Oct 20 '17 at 8:18
  • It's already in the answer
    – philsf
    Oct 20 '17 at 11:09
  • 1
    This only solves the first problem, but not the second one. See askubuntu.com/a/1125322/16985 Mar 13 '19 at 13:41
1

My ubuntu 18.04 with unity has the same problem.
Using the gconf-editor suggested by Martin, the box I need to uncheck located at /org/gnome/mutter/workspaces-only-on-primary.

1

18.04.1 LTS

https://askubuntu.com/a/393355/340383 is the correct answer. Posting this to warn others of what seems to me to be a bug:

Adding a checkbox beside Workspaces span displays inside the tweak tool has no effect:

broken workspaces tweaks window

I also could not find a /desktop/gnome/shell key shown by gconf-editor as indicated by the https://askubuntu.com/a/393355/340383 answer.

Update 2019-03-22 07:03: Please also read the commentary for this answer, as the "does NOT have any effect at all" in the picture above may be invalid with subsequent releases after 18.04.1 LTS, and that I've not retried the setting since I posted this answer.

6
  • what do you mean by no effect? it solves one of the two problems by OP, at least on 18.04.2 LTS Mar 13 '19 at 13:42
  • "it solves" is ambiguous. Please specify which of the answers you are referring to that solves the problem. And I do not see that the OP has marked any of the answers as the correct answer yet.
    – bgoodr
    Mar 14 '19 at 13:58
  • 1
    I was referring to the action (changing the Display Handling setting to Workspaces span displays, mentioned by multiple answers above) that you claim to “NOT have any effect” at all. Contrary to your claim stated in red, it indeed solves the first half of the problem in the question (leave one monitor as "fixed"). for the second half (there is no preview in the Activities view), see askubuntu.com/a/1125322/16985 Mar 18 '19 at 11:19
  • 1
    I added Update 2019-03-22 07:03 to warn others about the information being "stale".
    – bgoodr
    Mar 22 '19 at 14:04
  • 1
    Oh, I have not noticed the version difference. That makes sense. Thanks for the edit. Mar 22 '19 at 14:04
0

found another nice solution where both monitors have separate workspaces:

git clone git://github.com/spin83/multi-monitors-add-on.git
cd multi-monitors-add-on
git branch -a && git checkout gnome-3-32_3-36
cp -r multi-monitors-add-on@spin83 ~/.local/share/gnome-shell/extensions/

alt + F2 type in r then enter

then, you can open your tweaks application on Ubuntu, described above and find there extensions and activate multi-monitors add-on if it's not already activated.

Note: I struggled with error where extension could not have been properly loaded due to errors, you can debug them by reading journal log output:

sudo journalctl /usr/bin/gnome-shell

if that's the case try switching the branch in repository above

or report the error to the owner on GitHub

https://github.com/spin83/multi-monitors-add-on.git

Good luck everybody :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.