Is there a way, to change the broadcast address for network config via GUI?

if I set my network config to "auto", connection establishes with following information for IPv4:

  • IP-Address:
  • Broadcast-Address:
  • Subnet mask:
  • Gateway:
  • Primary DNS:
  • Secondary DNS:

If I set it to "manual" and fill out:

  • IP-Address
  • Subnet mask
  • Gateway and
  • DNS Server

...with the information from above (exept IP address:, the connection won't establish and "Broadcast-Address" differs:

  • Broadcast-Address:

Aim: I want to access my desktop ubuntu with my phone within the local network. Therefore my pc needs a static IP and the broadcast address is wrong, right?

network config for IPv4 - manual settings


@migrc: my ping output

breaker222@breaker222-ubuntu-studio:~$ ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=64 time=0.247 ms
64 bytes from icmp_seq=2 ttl=64 time=0.301 ms
64 bytes from icmp_seq=3 ttl=64 time=0.331 ms
64 bytes from icmp_seq=4 ttl=64 time=0.294 ms
64 bytes from icmp_seq=5 ttl=64 time=0.289 ms
64 bytes from icmp_seq=6 ttl=64 time=0.297 ms
64 bytes from icmp_seq=7 ttl=64 time=0.256 ms
64 bytes from icmp_seq=8 ttl=64 time=0.940 ms
--- ping statistics ---
8 packets transmitted, 8 received, 0% packet loss, time 6999ms
rtt min/avg/max/mdev = 0.247/0.369/0.940/0.217 ms

edit 2

I've solved my problem, by creating a fix-ip-rule (ger: "feste IP Adresse") for my pc within my router options. To do so, I've entered the gateway IP "" in my browsers address bar and navigated to the "Network > LAN" Menu, where I've found the Option - and all without the need of console usage :) enter image description here

1 Answer 1


I think there is something incorrect in your configuration (when it's set in auto). With the netmask and ip address you are using you should not be able to reach the ip (gateway and primary dns), in fact you should not be able to reach any 192.168.1.x ip address. Try to ping to and check if you have response.

PD:This should be a comment but I haven't enough reputation

  • thanks for your comment - see my Question edit for the terminal output. I think this is a response.
    – Breaker222
    Oct 20, 2015 at 16:42
  • I see. I was wrong, sorry. You can also change network configuration without GUI (if it is a valid solution for you). Take a look at help.ubuntu.com/community/NetworkConfigurationCommandLine
    – migrc
    Oct 21, 2015 at 7:34
  • 1
    I've solved it another way - but thanks again for your participation. That motivated me to keep on trying :)
    – Breaker222
    Oct 21, 2015 at 12:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.