I had Ubuntu 11.04 installed for a while and that worked fine. But when I try to boot from the Ubuntu 11.10 Live CD, the screen gets black after the purple background of what used to be the selection menu (where you could set boot options etc.). I tried to boot with nomodeset. It then boots fine, but as soon as X needs to be started for Ubiquity to display, the screen falls to black again. With noapic it starts almost fine (I can even hear the login sound), but still a black screen and no access to a tty.

My system specs:

Processor: AMD A4-3300M
Video card: ATI Radeon HD 6480G

Can somebody help me?

3 Answers 3


While I don't have the same laptop, I do have the same APU (A4-3300m | ATI Radeon HD 6480g).

I was having the same issue as you, but I was able to get Ubuntu 11.10 (fresh install) by doing the following:

1) Go here and download the alternate install liveCD: http://mirror.bytemark.co.uk/ubuntu-releases/oneiric/

2) Boot and install from the alternate LiveCD

3) After installation, boot with nomodeset

4) Drop into TTY, log in as usual

5) Install fglrx: sudo apt-get update && sudo apt-get install fglrx

6) After it's finished, just reboot and boot normally. You should be able to boot into Ubuntu 11.10.

Also, I should mention that everything will seem kind of sluggish. If you install compizconfig-settings-manager and turn off "Sync to Vblank" in General --> OpenGL, everything will be visibly faster and smoother.

  • Thanks, it inspired me to make the liveCD work. I'll use your idea in my answer!
    – antivirtel
    Jan 8, 2012 at 10:28

I had similar problem. And I solved it like this:

  • re-boot without the LiveCD to your current Ubuntu version, refresh the configuration of Grub with this command sudo update-grub

  • then boot with your LiveCD 11.10

From what I've understood, GRUB manages the way to start Ubuntu when several versions have been installed. The command sudo update-grub will clean it, that way your LiveCd won't have problem to run.


I have an E525, and I successfully booted from a Live CD (USB - I've used an USB drive!!! Not CD). Thanks Isaac Joseph for the idea (package name) mentioned in his answer.

  1. Boot up till the the Keyboard=Accessibility screen, push any keys, select your language. Keyboard=Accessibility screen

  2. Push F6 for other options, select nomodeset. Boot! other options

  3. You will see a tty console, connect Ethernet cable, or just set up Internet connection.
  4. Update packages, and install fglrx (driver) packatge: sudo apt-get update && sudo apt-get install fglrx
  5. After the successful installation, you can start the desktop manager: sudo service lightdm start
  6. You're done. Try or install the 11.10.

For geeks or when the first doesn't work:

  1. The laptop has an UEFI boot first option in BIOS.
  2. After this setting, booting from USB displays a GRUB 1.99 menu with 3 entries: Install, Try or Repair disk. Highlight Try, hit E.
  3. Go to end of the long line ending with --, write nomodeset before -- (separate with a space!).
  4. Hit F10 (or Fn+F10 with newer settings), then it boots to a tty console.
  5. Follow the previous instructions from 3rd point.

I hope it helped.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .