3

I have recently installed Ubuntu 15.04, and with it the latest stable version of the nVidia Display Driver (352.55) for my GTX 650, downloaded from the community nVdia driver repository.

After setting my resolution to 1360x768 (I have a 16:9 monitor), though, the screen looks stretched horizontally and the rightmost part of the displayed image is not shown on the monitor. Vertically, the image is displayed fine and doesn't look stretched.

If I take a screenshot, the size of the saved picture is 1360x768, which means the resolution is correctly set, it will simply look stretched beyond my monitor's display area.

I've searched Google for days, but I simply cannot find a solution for this. Can anyone provide help?

2

I tried again after a couple months and found the solution, I decided to post it here since the same problem could affect someone else and the question got an upvote in the meantime.

Basically, the problem was the monitor "clock" setting being way off and failing at auto-adjusting itself with the auto-adjust function.

Step by step solution that worked for me:

  1. Set the desired resolution in the NVidia X-Server Settings application.

  2. Press the auto-adjust button on your monitor.

  3. Look for the "clock" setting in your monitor settings menu, then start reducing its value. My monitor didn't allow it to be reduced below a threshold (it was set at 50 and couldn't go below 0). If your monitor allows you to reduce the clock value as much as you need to, don't look at the steps below.

  4. Press the auto-adjust button again, this put the clock value in the settings to 50 again without setting the picture back to its initial stretched state for me.

  5. Reduce the value of the clock setting again.

If it's not enough yet (like it was in my case, as the picture was very stretched), repeat steps 4 and 5 until the picture fits the screen.

0

The solution above didn't work for me. You can solve the problem by changing the frequency setting (next to "resolution" setting which might be set Auto by default) to any other option available. The setting is in the menu of the program: NVIDIA X Server Settings > X Server Display Configuration.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.