I have a keyboard without the NumLock key. The keyboard is a Dell wireless one, similar to the MAC one. It has a clear key rather than NumLock like in older keyboards. How can I toggle the NumLock on and off?

  • Maybe you can map a physical key you don't need on your keyboard to act as NumLock?
    – Byte Commander
    Commented Oct 19, 2015 at 11:06
  • If the keyboard doesn't have a NumLock key, chances are the number pad doesn't support sending the alternate keystrokes, which means that even if you managed to map a NumLock key, it just wouldn't do anything. Commented Oct 19, 2015 at 11:28

2 Answers 2


Using super-user rights:

Install numlockx:

sudo apt-get install numlockx

Turn off Num Lock with numlockx off.

Turn it on with numlockx on.

Without super-user access:

gedit ~/.xinitrc

Add the following line:

/usr/bin/numlockx on

Unfortunately, you need the package numlockx for the above...

  • thanks. Unfortunately i do not have administrator rights. Is there a way to figure out where the numlock key is on a keyboard? or to toggle it with a click somewhere?
    – dodohjk
    Commented Oct 19, 2015 at 10:45
  • @dodohjk new edit
    – TellMeWhy
    Commented Oct 19, 2015 at 10:50

You may have the On Screen Keyboard installed. In the dash, search for Onboard.

Onboard on-screen keyboard

The NumLock key is on the numerical page, under the "123" key on the lower right.

  • thanks, this solves the issue. I still wonder where the Numlock key is on my keyboard
    – dodohjk
    Commented Oct 19, 2015 at 13:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .