4

There are a lot of questions around this, I must have gone though about 10 to see what's wrong. I have a Behringer FCA610 usb audio interface that I use as my primary card. In Ubuntu 14.10, I simply used qJackCtl, went to Setup>Settings then under interface selected in the dropdown the FCA610 which was displayed.

I upgraded to 15, had some issues, and had to reinstall. I'm not trying to get this working again. There are 2 listings under interface for FCA610. One is listed as

hw:FCA610 (FCA610 hw:5)

and the other is listed as

hw:FCA610,0 (USB Audio hw:5,0)

I have tried both then saving and hitting the start button, but neither results in displaying the audio interface in the sound settings like it used to.

There is no listing for the FCA610 in Output, but I did notice a listing for Input as

FCA610 Multichannel

Everything is pointing to my card being recognized. I was able to use the FCA610 using an aplay command, even.

My /proc/asound/cards listing is as follows:

0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xdf430000 irq 38
 1 [NVidia_1       ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xdf080000 irq 17
 2 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xdd080000 irq 19
 3 [O25            ]: USB-Audio - Oxygen 25
                      M-Audio Oxygen 25 at usb-0000:00:14.0-9, full speed
 4 [BCR2000        ]: USB-Audio - BCR2000
                      BEHRINGER BCR2000 at usb-0000:00:14.0-10, full speed
 5 [FCA610         ]: USB-Audio - FCA610
                      BEHRINGER FCA610 at usb-0000:00:14.0-14, high speed

listing for aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC1150 Analog [ALC1150 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC1150 Digital [ALC1150 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia_1 [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia_1 [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia_1 [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia_1 [HDA NVidia], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 5: FCA610 [FCA610], device 0: USB Audio [USB Audio]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

I looked into editing the alsa config file but i'm frankly not familiar with it and the things i changed didn't help anyway.

I'm not sure how to configure this so that it is properly showing in the outputs/playback

  • Bug in PulseAudio. – CL. Oct 18 '15 at 19:31
8

Was able to finally find the answer after about 2 weeks of looking. First, run

aplay -l | grep card

This should list the devices alsa can see. Pulseaudio sits on top of alsa, so alsa needs to be able to see the device before pulseaudio can. In my case, alsa was able to see my usb audio interface, but it was not showing up in the pulseaudio list correctly.

The next step is to run

gksu gedit /etc/pulse/default.pa

this is the file that was escaping me for a while, and it essentially sets defaults for pulseaudio. In order to get it to correctly see the card, go to the bottom of the file and append:

load-module module-alsa-sink device=hw:0

here, the 0 is replaced by whatever device number the card that is not appearing is. Save the file and log out, then log back in and your device should appear in the list.

I'm still not sure why alsa could see the device but pulseaudio could not, but this effectively adds the item to the list and allows you to run your usb audio interface without having to run QJackCtl.

| improve this answer | |
  • 1
    It didn't work for me. When I added it the volume settings stopped working – makkasi Mar 20 '19 at 7:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.