6

UPDATE: Problem solved with 16.04.

I have an Asus Zenbook UX32V. I installed Ubuntu 14.04 and now I cannot browse the Internet. When I connect to a wireless network everything is fine for 2-3 minutes and the browser (Chrome or Firefox) stops opening web pages. But torrent, skype and whatsapp web (if started before the problem began) works fine. My phone and windows computer can go online too. If I disable and re-enable networking, I can open web pages for another 2-3 minutes and problem repeats.

lspci -knn | grep Net -A2

outputs:

03:00.0 Network controller [0280]: Intel Corporation Centrino Advanced-N 6235 [8086:088e] (rev 24)
    Subsystem: Intel Corporation Centrino Advanced-N 6235 AGN [8086:4060]
    Kernel driver in use: iwlwifi

I tried these:

None of them worked. Because I messed with a lot of settings in different combinations, I formatted the computer and installed Ubuntu all over again.

How can I fix this problem?

13
  • Try options iwlwifi 11n_disable=1
    – Pilot6
    Oct 18, 2015 at 11:34
  • 1
    Have you tried another wireless connections (like public wifi in cafe...)? Oct 21, 2015 at 8:46
  • Can you open IP addresses in your browser instead of URLs after it crashed? Try 109.193.193.109 which is one of the IPs that google.com uses. You can also try the tool nslookup, which allows you to resolve URLs to IP addresses. You can change the DNS server it uses with the interactive command server 8.8.8.8 for google's DNS for example.
    – Byte Commander
    Oct 21, 2015 at 18:31
  • @Byte Commander I cannot ping 109.193.193.109 or 8.8.8.8 dns server.
    – b4da
    Oct 22, 2015 at 10:00
  • Maybe it is problem with torrents. If in your torrent-client are allowed to many connections it can slow down networking in the whole system. Please post preferences of your torrent here.
    – UNIm95
    Oct 24, 2015 at 16:50

1 Answer 1

2

The problem is one of 3 things. It's either a hardware/device issue, a networking stack issue, or a DNS issue.
The hardest to identify is a device issue, so lets consider that last.

The easiest to diagnose is a networking issue. During an outage: Try running ifconfig in a console. It should show a configured device with an IP address. At the very least you should be able to ping that, thus you can generate packets.
Run route to see what your default Gateway is, and try pinging that. If there is no default gateway, or you can't ping the default gateway, that's your problem there. If you can, then try pinging 109.193.193.109 and if that fails (ICMP echo could be blocked on your network, like it is on mine), try visiting http://109.193.193.109 in a browser. If that works, it's most likely a DNS issue.

DNS Issues: Try or ping www.google.co.uk (if dnsutils isn't installed). It should present an IP address. In my case it's 216.58.219.99. If it doesn't, you'll need nslookup/dig (from the dnsutils package) to diagnose. nslookup will tell you the Server Address, and hence tell you which DNS server is supposedly serving your requests. If it's not working, you may have a badly configured system, or a broken DNS server. I would suggest you try installing a local DNS server (install package bind9 and setup 127.0.0.1 as your DNS server), or try re-configuring NetworkManager. I've found it nothing but trouble.

As for device issues. If the appropriate device appears in ifconfig , then it's probably not going to be a device problem that you can fix, but judging from what you said above, I doubt it's a device problem, unless it's as silly as a bad cable/connector in your computer/router, but I have had issues with the Raspberry Pi, which turned out to be sufficient power on the board to run the device and detect it, but not enough to interrogate (running ifconfig resulted in a device failure).

0

Not the answer you're looking for? Browse other questions tagged .