1

Total newbie here. I want to install Ubuntu 14.04.3 alongside Win 8.1 that's already there. I'm getting the same error no matter what - "The attempt to mount a file system with type vfat in SCSI1 (0,0,0), partition #1 (sda) at /boot/efi failed. I tried all of the following:

  1. Selected "install ubuntu alongside windows..." - result is that installation stalls.
  2. Selected "something else" and tried creating 3 manual partitions: ~45GB for root ("/") as ext4, ~17GB for swap, ~30GB as ext4 for "/home". Result - the above error message.
  3. Somebody had suggested partitioning using GParted and then running installer.. Tried this too, but GParted doesn't let me partition as "Logical".. I only see "primary".. But, even then in GParted, I don't see an option to set "/" or "/home" etc.. So I got to do this in the installer? If yes, then what's the point in partitioning beforehand?

Any help is greatly appreciated! Thanks!

  • please refer here – Ravan Oct 18 '15 at 6:28
  • You man need to run chkdsk from Windows on sda1 or sudo fsck.vfat -t -a /dev/sda1 from live installer. With UEFI you have gpt which does not have logical partitions only primary. If you create partitions with gparted, you must use Something Else to tell installer which partition is / (root) and which is /home. It will find swap automatically. – oldfred Oct 18 '15 at 13:48
  • Thanks! I've done a checkdisk on windows, but it returned no errors. But when I tried 'sudo fsck.vfat -t -a /dev/sda1' on linux, it gave me an error like "fsck error: currently, only 1 or 2 FATs are supported, not 0". Also, I have double checked that the fastboot is disabled.. Can you pls tell me what other tool I need along with GParted to get this job done, because I have read at many places that those with a similar problem got it to work by partitioning using GParted and then installing. Thanks in advance!' – VinVin Oct 18 '15 at 19:34
1

You probably need to disable a Windows feature called Fast Startup, as described here (among other places):

http://www.eightforums.com/tutorials/6320-fast-startup-turn-off-windows-8-a.html

This feature turns a shutdown operation into a suspend-to-disk operation. The result is often filesystem corruption or an inability to mount shared partitions (including the EFI System Partition, or ESP) from non-Windows OSes.

If disabling Fast Startup doesn't do the job by itself, then I recommend you run a filesystem check on the ESP, as oldfred suggests.

  • Thanks, the fastboot is disabled.. and the filesystem check returned no error in windows, but in linux I got an error - "fsck error: currently, only 1 or 2 FATs are supported, not 0" Any idea how I can get around? – VinVin Oct 18 '15 at 19:38
  • First, note that it's the Windows feature called Fast Startup you need to disable. Many EFIs provide a feature with a similar name ("fast boot," etc.), but that feature is irrelevant to this discussion. Second, if you're continuing to see filesystem errors on your EFI System Partition (ESP), then you might consider backing it up, creating a fresh filesystem on that partition, and restoring the files to it. You may need to edit /etc/fstab to refer to the new "UUID" (really a serial number) after you make this change. – Rod Smith Oct 19 '15 at 15:48
  • Yeah, the windows fast startup was disabled. #2: The partition that's returning the error is actually completely empty.. So I formatted it and created new filesystem numerous times.. Still no luck. Can you please instruct me how exactly to use /etc/fstab ?(total novice!) Thanks again! – VinVin Oct 19 '15 at 16:02
  • For /etc/fstab, see help.ubuntu.com/community/Fstab, although I think that's starting to veer off track from your real problem. If you're seeing that error after using Windows, I still suspect you haven't properly disabled the Windows Fast Startup feature. If the problem occurs even when Windows has not been used, then it's something else, such as your disk going bad. – Rod Smith Oct 19 '15 at 18:22
0

Don't know if this will help much, but, when i tried to install ubuntu on a machine that had windows 7 already, I first also tried to create a "ext4" partition manually. This didn't work. Then, I tried to create a "ext3" partition manually. That did the trick. However, before completing the installation of ubuntu, the system froze a few times. Then everything worked all right.

  • Thanks a ton.. I'll try this if I can't find any other way. :) – VinVin Oct 18 '15 at 19:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.