I have done pretty much everything I guess. I just want to format my micro-SD card so I can write a Raspbian image to it for my RPI. To begin with I am pretty new at Ubuntu so I am pretty sure that I probably did something that "destroyed" my micro-SD.

These are the commands I used:

sudo -i
umount /dev/mmcblk0p1
dd bs=4M if=2015-09-24-raspbian-jessie.img of=/dev/mmcblk0

After 24+ hours I got impatient and just closed the terminal (I know now that this was probably not the smartest thing to do... and this is probably what destroyed my SD-card)

  1. I tried using disks but it gives me an I/O error...
  2. I tried using gparted but right after creating the FAT32 system, gparted just keeps searching and nothing happens...
  3. I tried using testdisk but with no luck...
  4. I have tried using fdisk but with no luck...
  5. I have not yet tried on a different OS and I do not know if that would even work

Dmesg output:

[   87.292298] mmcblk0: error -110 transferring data, sector 2, nr 6, cmd response 0x900, card status 0x0
[   87.292305] end_request: I/O error, dev mmcblk0, sector 2
[   87.293240] mmcblk0: error -84 transferring data, sector 3, nr 5, cmd response 0x900, card status 0x0
[   87.293245] end_request: I/O error, dev mmcblk0, sector 3
[   87.294110] mmcblk0: error -84 transferring data, sector 4, nr 4, cmd response 0x900, card status 0x0
[   87.294115] end_request: I/O error, dev mmcblk0, sector 4
[   87.296545] Buffer I/O error on device mmcblk0, logical block 0
[   87.297431] ldm_validate_partition_table(): Disk read failed.
[   87.297437] Dev mmcblk0: unable to read RDB block 0
[   87.298347]  mmcblk0: unable to read partition table

The output to fdisk – l:

Disk /dev/mmcblk0: 7746 MB, 7746879488 bytes
4 heads, 16 sectors/track, 236416 cylinders, total 15130624 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Disk /dev/mmcblk0 doesn't contain a valid partition table

I know there are no valid partitions and that happened after I tried:

sudo dd if=/dev/zero of=/dev/mmcblk0 bs=512

I just want to know if it is even possible to repair my micro-SD card?

1 Answer 1


Have you tried using a different card reader or checking possibilities of it being some other device? (Yes, I know I should use comments, but I can't)

  • I have not tried using another card reader. I am using the one that are integrated in my laptop. I am not sure what you mean by "it being some other device"? I am 100% sure that /dev/mmcblk0 is my sd card if that is what you meant. Oct 18, 2015 at 1:32
  • @OneFiveZero Try another card reader, integrated ones are usually junk. And I did mean it might be something else in /dev.
    – FireFaced
    Oct 18, 2015 at 1:38
  • Okay I will try formatting it on my friend's laptop with windows and his card reader. If that does not work either I will buy new card reader and probably a new micro sd card. Oct 18, 2015 at 1:44
  • @OneFiveZero Okay
    – FireFaced
    Oct 18, 2015 at 1:45
  • Well I have just tried my friends laptop with his card reader and in 20 min I had formatted and installed raspbian on my rpi and it works great. Thank you for your help. Oct 18, 2015 at 18:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.