1

I tried upgrading Ubuntu from 12.0 to 14.0 and the upgrade failed. However, when I tried to start apache2 afterwards, it fails with the message:

*Starting web server >apache2 * * The apache2 configtest failed. Output of config test was: AH00534: apache2: Configuration error: No MPM loaded. Action 'configtest' failed. The Apache error log may have more information.

But apache2/error.log does not have any entry pertaining to this failure.

  • I think this is due to the transition from Apache 2.2 to Apache 2.4. (It looks like someone didn't read the Release Notes.) – John Scott Oct 17 '15 at 16:56
  • I'm a newbie to ubuntu, don't understand much of apache configuration, that's why I asked, if you can help I'll appreciate – user188606 Oct 17 '15 at 17:33
  • I don't know much about Apache configuration either, so I can't really help you, sorry. I upvoted the question, maybe someone more knowledged than us will help. I'm curious to see how this is fixed, I'm eager to learn more about Apache. Have you modified your Apache configuration file? If you haven't made any important tweaks to Apache, it might just be easier to purge Apache and reinstall. – John Scott Oct 17 '15 at 20:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.