0

Abstract : I've installed enhanceIO and enhanceio-dkms from the daily PPA at http://ppa.launchpad.net/enhanceio/daily/ubuntu/ giving version 0+git20130406-0~69~ubuntu14.04.1. Everything seems to be working well, except that the udev rules do not fire on reboot.

The HDD is an LVM logical volume (just data, not root or boot), while the SSD is a partition on the SSD. I've also tried with the whole SSD. Upon reboot, /proc/enhanceio only contains a single "file", version.

I've referenced the SSD as the straight device (/dev/sde2) and as the by-id link (ata-ADATA_SP600_7D4020501003-part2) to no avail. After reboot I have to recreate the cache from scratch with :

sudo eio_cli create -d /dev/nzbzzz/resources -s /dev/sde2 -m wb -c ResourcesCache

The udev rule references the devices like this :

ENV{ID_SERIAL}=="ADATA_SP600_7D4020501003", ATTR{partition}=="2", GOTO="EIO_CACHE"

and

ENV{DM_UUID}=="LVM-AxrxJLdH2BHt9FV71H7Zk73Qj1uGdc1WiJJppGgpiqLlbs0W4XnCz2vhAPl17i9w", ENV{DEVTYPE}=="disk", GOTO="EIO_SOURCE"

The rules have not been modified, they're just what the eio_cli create command creates.

Any ideas ?

0

You DO NOT need to rebuild your cache, eio_cli enable should be enough. I can confirm the created udev rules are broken in Ubuntu 14.04.

Here a short output from re-activating an existing cache after reboot. I used RO though, in your case with WB mode a data loss is likely if you re-create or enable it after fsck has run. Basically you need to turn off auto vg activation or fix the udev rule.

root@xxx:/etc/udev/rules.d# eio_cli enable -d /dev/md126 -s /dev/md125 -p lru -c eio_vgdata1
root@xxx:/etc/udev/rules.d# cat /proc/enhanceio/
eio_vgdata1/ version      
root@xxx:/etc/udev/rules.d# cat /proc/enhanceio/eio_vgdata1/stats 
reads                                 0
writes                                0
read_hits                             0
read_hit_pct                          0
write_hits                            0
write_hit_pct                         0
dirty_write_hits                      0
dirty_write_hit_pct                   0
cached_blocks                     75858
rd_replace                            0

Remember by choosing to use Ubuntu you already made a choice to not have any reliable component in your system.

If I get this one chunk fixed proper I'll post back here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.