1

As the title says I've tried to install Ubuntu 14.04 on my PC alongside with Windows 8.1. I used LiLi USB Creator to create a bootable USB stick. The stick is recognized and I can choose it as a boot device. Then this little BIOS like menu pops up where I can choose between testing ubuntu, installing ubuntu, OEM installing ubuntu and check disk for errors or I can open grub. Whatever option I choose it all ends up in the same result (except grub, that seems to work). The following three lines appear for 1/10 second and then the screen stays black forever.

[   0.015480] Ignoring BGRT: invalid status 0 (expected 1)
[   2.700492] ACPI PCC proble failed.
|||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||

Here is what I've tried so far to get it running without success:

  1. Check if SecureBoot is disabled (it was)
  2. Disabled Windows 8.1 fast boot option
  3. Changed from ACPI to IDE and back
  4. Tried 3 different USB sticks and a SD Card

The strange thing is that Linux Mint works in live mode fine but always fails with an Input/Output Error while installing.

At last here are the PC specs:

ASRock Fatal1ty Z97X Killer

Intel Core i7 4790K

16GB Crucial Ballistix Sport RAM

2x Palit GeForce GTX970 Jetstream

Any help is appreciated

3
  • 1
    You need to boot with nomordest, install Ubuntu, then install Nvidia drivers.
    – Pilot6
    Oct 17, 2015 at 13:38
  • Did you verify the integrity of the disk image(s) used as source to create the installation media? Oct 17, 2015 at 14:15
  • I think @Pilot6 has a typo in his comment, and it's suppose to be nomodeset OP: You can try this method to achieve this: askubuntu.com/a/38834/443563
    – Promille
    Oct 17, 2015 at 14:34

1 Answer 1

1

The problem is the Nvidia GTX 970 is not compatible with nouveau display driver.

As Pilot6 said, you will have to install using nomodeset as a startup parameter during the installation.

After you have installed Ubuntu you have to startup using the recovery menu and install the xorg-edgers driver.

2
  • Ok that did the trick with the black screen but now I'm also getting the Input/Output Error for the ubuntu installer which previously occured on the Mint installer. Any idea what the problem there is?
    – Hibuja
    Oct 17, 2015 at 15:11
  • @Hibuja I/O error indicates your hardware may have issues - either the hard drive or the installation disk...
    – Thomas Ward
    Oct 31, 2015 at 19:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.