2

I installed ubuntu some days ago (15.04 64bits), I'm new on it.

I installed bumblebee and now that I try to install Wine, Steam or Skype I always get this error.

I've tried some solutions posted on forums ..etc. but still the same. "You are missing the following 32-bit libraries, and Steam may not run: libGL.so.1" I can't install these libraries.

I'm not familiar on ubuntu yet so I don't know what I need to mention in this post, I'll post everything necessary when you ask me.

Here is the error message.

The following packages contain dependencies unsatisfied :
 libgl1-mesa-dri:i386 : Depends: libdrm-amdgpu1:i386 (>= 2.4.63) but will not be installed
                    Depends: libdrm-intel1:i386 (>= 2.4.48) but will not be installed
                    Depends: libdrm-nouveau2:i386 (>= 2.4.38) but will not be installed
                    Depends: libdrm-radeon1:i386 (>= 2.4.31) but will not be installed
                    Depends: libdrm2:i386 (>= 2.4.38) but will not be installed
libgl1-mesa-glx:i386 : Depends: libdrm2:i386 (>= 2.3.1) but will not be installed

Thanks a lot :)

EDIT : output : apt-cache policy libgl1-mesa-dri:i386 libdrm-amdgpu1:i386 libdrm-intel1:i386 libdrm-nouveau2:i386 libdrm-radeon1:i386 libdrm2:i386 libgl1-mesa-glx:i386

libgl1-mesa-dri:i386:
  Installed : (none)
  Candidate : 11.0.2+git20151008+11.0.b1230e3e-0ubuntu0ricotz~vivid
 Version table :
 11.0.2+git20151008+11.0.b1230e3e-0ubuntu0ricotz~vivid 0
    500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu/ vivid/main i386 Packages
 10.5.9-2ubuntu1~vivid2 0
    500 http://fr.archive.ubuntu.com/ubuntu/ vivid-updates/main i386 Packages
 10.5.2-0ubuntu1 0
    500 http://fr.archive.ubuntu.com/ubuntu/ vivid/main i386 Packages
 9.1.1-0ubuntu3 0
    500 http://old-releases.ubuntu.com/ubuntu/ raring/main i386 Packages
libdrm-amdgpu1:i386:
  Installed : (none)
 Candidate : 2.4.65+git20151008.8c4a1cbd-0ubuntu0ricotz~vivid
Version Table :
 2.4.65+git20151008.8c4a1cbd-0ubuntu0ricotz~vivid 0
    500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu/ vivid/main i386 Packages
libdrm-intel1:i386:
Installed : (none)
Candidate : 2.4.65+git20151008.8c4a1cbd-0ubuntu0ricotz~vivid
Version :
 2.4.65+git20151008.8c4a1cbd-0ubuntu0ricotz~vivid 0
    500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu/ vivid/main i386 Packages
 2.4.60-2 0
    500 http://fr.archive.ubuntu.com/ubuntu/ vivid/main i386 Packages
 2.4.43-0ubuntu1 0
    500 http://old-releases.ubuntu.com/ubuntu/ raring/main i386 Packages
libdrm-nouveau2:i386:
Installed : (none)
Candidate : 2.4.65+git20151008.8c4a1cbd-0ubuntu0ricotz~vivid
Version table :
 2.4.65+git20151008.8c4a1cbd-0ubuntu0ricotz~vivid 0
    500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu/ vivid/main i386 Packages
 2.4.60-2 0
    500 http://fr.archive.ubuntu.com/ubuntu/ vivid/main i386 Packages
 2.4.43-0ubuntu1 0
    500 http://old-releases.ubuntu.com/ubuntu/ raring/main i386 Packages
libdrm-radeon1:i386:
Installed : (none)
Candidate : 2.4.65+git20151008.8c4a1cbd-0ubuntu0ricotz~vivid
Version table :
 2.4.65+git20151008.8c4a1cbd-0ubuntu0ricotz~vivid 0
    500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu/ vivid/main i386 Packages
 2.4.60-2 0
    500 http://fr.archive.ubuntu.com/ubuntu/ vivid/main i386 Packages
 2.4.43-0ubuntu1 0
    500 http://old-releases.ubuntu.com/ubuntu/ raring/main i386 Packages
libdrm2:i386:
 Installed : (none)
 Candidate : 2.4.65+git20151008.8c4a1cbd-0ubuntu0ricotz~vivid
Version table :
 2.4.65+git20151008.8c4a1cbd-0ubuntu0ricotz~vivid 0
    500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu/ vivid/main i386 Packages
 2.4.60-2 0
    500 http://fr.archive.ubuntu.com/ubuntu/ vivid/main i386 Packages
 2.4.43-0ubuntu1 0
    500 http://old-releases.ubuntu.com/ubuntu/ raring/main i386 Packages
libgl1-mesa-glx:i386:
Installed : (none)
Candidate : 11.0.2+git20151008+11.0.b1230e3e-0ubuntu0ricotz~vivid
Version table :
 11.0.2+git20151008+11.0.b1230e3e-0ubuntu0ricotz~vivid 0
    500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu/ vivid/main i386 Packages
 10.5.9-2ubuntu1~vivid2 0
    500 http://fr.archive.ubuntu.com/ubuntu/ vivid-updates/main i386 Packages
 10.5.2-0ubuntu1 0
    500 http://fr.archive.ubuntu.com/ubuntu/ vivid/main i386 Packages
 9.1.1-0ubuntu3 0
    500 http://old-releases.ubuntu.com/ubuntu/ raring/main i386 Packages

EDIT : apt-cache policy libgl1-mesa-dri:i386

 libgl1-mesa-dri:i386:
 Installé : (aucun)
 Candidat : 10.5.9-2ubuntu1~vivid2
 Table de version :
 10.5.9-2ubuntu1~vivid2 0
    500 http://fr.archive.ubuntu.com/ubuntu/ vivid-updates/main i386 Packages
 10.5.2-0ubuntu1 0
    500 http://fr.archive.ubuntu.com/ubuntu/ vivid/main i386 Packages
 9.1.1-0ubuntu3 0
    500 http://old-releases.ubuntu.com/ubuntu/ raring/main i386 Packages

EDIT : "sudo apt-cache policy libgl1-mesa-dri:i386"

*libdrm-intel1:
Installé : 2.4.65+git20150922.f3c6740f-0ubuntu0ricotz~vivid
Candidat : 2.4.65+git20150922.f3c6740f-0ubuntu0ricotz~vivid
Table de version :
*** 2.4.65+git20150922.f3c6740f-0ubuntu0ricotz~vivid 0
    100 /var/lib/dpkg/status
 2.4.60-2 0
    500 http://fr.archive.ubuntu.com/ubuntu/ vivid/main amd64 Packages

EDIT : sudo ppa-purge ppa:xorg-edgers/ppa

Updating packages lists
PPA to be removed: xorg-edgers ppa
Warning:  Could not find package list for PPA: xorg-edgers ppa

EDIT : sudo apt-cache policy libgl1-mesa-dri:i386

libgl1-mesa-dri:i386:
Installed : (none)
Candidate : 10.5.9-2ubuntu1~vivid2
Table de version :
 10.5.9-2ubuntu1~vivid2 0
    500 http://fr.archive.ubuntu.com/ubuntu/ vivid-updates/main i386 Packages
 10.5.2-0ubuntu1 0
    500 http://fr.archive.ubuntu.com/ubuntu/ vivid/main i386 Packages
 9.1.1-0ubuntu3 0
    500 http://old-releases.ubuntu.com/ubuntu/ raring/main i386 Packages
  N: « xorg-edgers-ubuntu-ppa-vivid.list.disable » in the repertory « /etc/apt/sources.list.d/ » was ignored because he uses an invalid extension
  N: « xorg-edgers-ubuntu-ppa-vivid.list.disable » in the repertory « /etc/apt/sources.list.d/ » was ignored because he uses an invalid extension
2
  • Please, don't change the question without that I say that. Sorry ;) That's too confusing. And don't delete the output of previous commands, also confusing for readers. And add changes at the end of your question.
    – A.B.
    Oct 17, 2015 at 16:00
  • Please remove your comments below your question
    – A.B.
    Oct 17, 2015 at 16:59

1 Answer 1

0

That looks very funny.

  1. Remove the old-releases repositories

    sudo sed -i '/old-releases/d' /etc/apt/sources.list
    sudo apt-get update
    
  2. You had the PPA ppa:xorg-edgers/ppa in your system, but deleted the file in /etc/apt/sources.listd. Therefore re-add and purge in a clean way

    sudo apt-add-repository ppa:xorg-edgers/pp
    sudo ppa-purge ppa:xorg-edgers/ppa
    

    and a little bit housekeeping

    sudo rm /etc/apt/sources.list.d/xorg-edgers-ubuntu-ppa-vivid.list.disable
    
  3. Repair your system

    sudo apt-get install -f
    
0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .