0

This question already has an answer here:

I installed Ubuntu 14.04.30 LTS using a USB stick. I didn't dual boot my pc, I deleted my old OS. I can't find Enable Wireless in the network menu. The output for rfkill

----------------------------------
rfkill list all
0: hci0: Bluetooth 
        Soft blocked: no
        Hard blocked: no
-----------------------------------

The output for lshw -c network

*-network
      description: Network controller
      product: BCM4312 802.11b/g LP-PHY
      vendor: Broadcom Corporation 
      physical id: 0
      bus info: pci@0000:03:00.0
      version: 01
      width: 64 bits
      clock: 33MHz
      capabilities: bus_master cap_list
      configuration: driver=b43-pci-bridge latency=0
      resources: irq:18 memory:99700000-99703fff
*- network 
      description: Ethernet interface 
      product: RTL1801E/RTL8102E PCI Express Fast Ethernet controller 
      vendor: Related Semiconductor Co., Ltd.
      physical id: 0
      bus info: pci@0000:04:00.0
      logical name: eth0
      version: 02
      serial: 00:1e:ec:a1:73:dd
      size: 10Mbit/s
      capacity: 100Mbit/s
      width: 64 bits
      clock: 33MHz
      capabilities: bus_master cap_list rom Ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation

I am new to Linux and have no idea what to do. I can see the WiFi symbol at the top right corner of the screen. But its blank. When I click on it I can see that Enable Networking is checked. The other options are Edit connections & VPN connections. I don't have access to internet. Can't use Ethernet as a WiFi network is all I can access. I have just downloaded Ubuntu 14.04.3 and haven't installed any drivers or packages

marked as duplicate by Pilot6, Eric Carvalho, user364819, hg8, Kevin Bowen Oct 22 '15 at 3:05

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • It would maybe help you to get some responses if you extended your answer with a walkthrough of your interactions, and explain us where it fails. Is the wireless symbol showing in the top-right corner? If it is, can you find any network if you click it? edit your answer with this information in that case. – Promille Oct 17 '15 at 10:24
  • I cannot install Drivers as I'm not connected to the internet. Is there any other way in which I can install them? From a USB perhaps? – Sandhya Tiwari Oct 17 '15 at 11:17
  • Please edit your question and add output of lspci -knn | grep Net -A2 terminal command. – Pilot6 Oct 17 '15 at 12:19
0

You can install the Broadcom 4312 driver through the terminal with these commands :

sudo apt-get update

then

sudo apt-get install bcmwl-kernel-source

Once installed just reboot and then it should be working.

If that doesn't work you can try this:

Search Additional Drivers and once there you have to click on Broadcom STA wireless driver and enable it.

Restart and see if that works for you.

The last thing i would recommend to you is reinstall Ubuntu and when it asks if you want to install the 3rd party software (restricted extras) then make sure that it is ticked. Once Ubuntu finishes installing your wifi should be working on first boot.

You might need to install an additional driver once you are connected to the wifi because the restricted extras driver might be unstable but it should work enough for you to install the other driver.

Check my post here for additional help.

  • this is the error being displayed: Ign cdrom://Ubuntu 14.04.3 LTS Trusty Tahr - Beta amd64 (20150805) trusty InRelese Could not resolve 'archive.canonical.com' Err extras.ubuntu.com trusty InRelease Err security.ubuntu.com trusty-security Release.gpg Could not resolve 'security.ubuntu.com' Err us.archive.ubuntu.com trusty-backports Release.gp W: Some index files failed to download. They have been ignored, or old ones used instead. – Sandhya Tiwari Oct 17 '15 at 11:33
  • My apologies, ignore the first part (terminal commands) i didn't notice you had no wifi source. Try the bottom two and see if they help. – William Oct 17 '15 at 11:39
  • This is a wrong driver for this adapter. – Pilot6 Oct 17 '15 at 12:20
  • @Pilot6 Instead of dismissing everyone's advice why not actually contribute to the actual question. Installing the 3rd party extras will get the BCM4312 to work. It will be unstable but the author of the post needs a wifi connection for a while until they can download the correct driver (a more stable driver). – William Oct 17 '15 at 12:25
  • Thnk you @William. I reinstalled Ubuntu and now I'm able to see all available WiFi networks and connect as well. – Sandhya Tiwari Oct 17 '15 at 12:32
0

You can install bcmwl driver from USB. open terminal(Ctrl+Alt+T) and enter these commands:

cd /"path_to_USB_directory"
sudo dpkg -i pool/main/d/dkms/*.deb
sudo dpkg -i pool/restricted/b/bcmwl/*.deb

Then reboot your system.

-1

Been their try this

‪ ‎sudo‬ apt-get install build-essential linux-headers-generic git ‪ ‎

mkdir‬ ~/RTl8188EU

‪cd‬ ~/RTL8188EU

‪‎git‬ clone git://github.com/lwfinger/rtl8188eu

cd ~/RTL8188EU/rtl8188eu

sudo make

sudo make install

sudo cp -v ~/RTL8188EU/rtl8188eu/rtl8188eufw.bin /lib/firmware/rtlwifi/

sudo deomod -a

sudo update-initramfs -u

sudo modprobe 8188eu

  • Why do you suggest installing a Realtek driver for a Broadcom adapter? It is 100% wrong. – Pilot6 Oct 17 '15 at 11:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.