1

How can i install, from packages, Boost 1.55 on Ubuntu 15.10? For example, the repository (via Synaptic) only shows Boost 1.58 only, and Emulationstation (the version i have as tarball) uses Boost 1.55 as dependency - i have 1.58 installed, and terminal shows "emulationstation: error while loading shared libraries: libboost_system.so.1.55.0: cannot open shared object file: No such file or directory"

2

This can be really bad for your system.
The best thing to do is to clone the source code and compile it yourself.

(it doesn't look that hard: https://github.com/Aloshi/EmulationStation)


But if for some reason you really want to install an old version of libboost you can do it that way:
(I really don't recommend doing that unless you know what you're doing,
you can damage your system)

Download from here the packages suitable for your OS:
http://archive.ubuntu.com/ubuntu/pool/main/b/boost1.55/

Ror 64bit download libboost1.55-dev_1.55.0+dfsg-3ubuntu2_amd64.deb
For 32bit download libboost1.55-dev_1.55.0+dfsg-3ubuntu2_i386.deb
If you run something else download libboost1.55-doc_1.55.0+dfsg-3ubuntu2_all.deb

0

If it's available in your current apt sources, you can install it using the below steps:

  1. Press CTRL+ALT+T

  2. Type sudo apt-get install libboost1.55*

  3. If prompted type in your password (When you type in your password nothing will show up, this is normal)

  4. If prompted type y to confirm that you want to install it.

  5. Profit! If all went well, then congrats! You successfully installed it!

5
  • i tried "sudo apt-get install libboost*=1.55" and said "E: Version '1.55' for 'libboost(...)' was not found" – Paulo Silva Oct 17 '15 at 10:48
  • Got it! Look at the updated answer! – Grammargeek Oct 18 '15 at 1:04
  • i think that didn’t work because 1.55 isn’t there in the repository, only 1.58, which doesn’t work - perhaps i need to add the repository from a previous ubuntu version, or maybe create file links of 1.58 renamed as 1.55? or perhaps adding a ppa from somewhere? which is the best approach? – Paulo Silva Oct 19 '15 at 19:20
  • I know, that's why I suggested the above. The above is available from the default sources – Grammargeek Oct 19 '15 at 22:57
  • i tried that, but that is going to install the missing libboost1.58*, not libboost1.55* – Paulo Silva Oct 20 '15 at 16:54
-1

This will cover the bases for you:

sudo apt-get install libboost-all-dev

It works for me when I have a libboost_system.so.1.55.0 dependecy (or any libboost dependency) not meet on system.

Hope it helps!

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.