1

I recently installed Ubuntu on my laptop (14.04.3). Yesterday I installed League of Legends via PlayOnLinux. I am not saying "tried to install", because it installed and patched perfectly fine, and the client works, too.

I can log in, send messages, click on "Play", create a custom game (haven't tried any other type of game, for obvious reasons), pick a champion. And that's it. At the point where the game should start, where the client disappears and the loading screen would usually pop up, nothing happens. The client minimizes and then the Wine logo peaks out of the hidden launcher again shortly after that, as if it was going to open up a new window, but it doesn't.

Wine still shows the client as running, but I can't open it and when I open the task manager in POL "Wine" configuration it says it is not responding.

I tried changing PlayOnLinux/Wine settings in several ways. When I ticked "emulate virtual desktop" in Wine configuration, everything went the same except that I was now stuck in a not responding full screen virtual windows desktop. I have the Windows version set to XP, but I also tried Windows 8. I installed Internet Explorer 8, I even un- and reinstalled PlayOnLinux as well as LoL yesterday. I patched with loltux. Nothing changes.

It might be relevant that I am using AMD graphics with fglrx driver. I can give more information and debug if needed.

I have no idea what to do. I have searched all related forums, but just installing POL and LoL seems to work for everyone else and those who have problems apparently don't have the same one as me.

I might just be missing something important, I'm new to Ubuntu and haven't used Linux that much before. I'd appreciate any help and/or ideas on what could be the problem.

  • It does not work at all, according to it's wine hq listing, no loading screen or game play, exactly like you experienced appdb.winehq.org/… – Mark Kirby Oct 16 '15 at 11:29
  • Yes League of Legends should work after some tweaking. I think you would get more constructive responses by asking this question at winehq.org ( I'm not entirely sure how active their forum is) or at their IRC-channel: #winehq @ irc.freenode.org – Promille Oct 16 '15 at 11:33
  • 1
    @Wildcard Just found this listing now, don't know why, I did not see it before, but it seems you are correct it SHOULD work, this contains all steps the user used to get it working, still no promises though appdb.winehq.org/… – Mark Kirby Oct 16 '15 at 11:36
  • It's been a while since I've run LoL on linux, but I remember I used a patch but later someone found out you could change one variable in a config file to enable OpenGL. Don't have time to research it now, but I'm sure it's mentioned here in the comments appdb.winehq.org/objectManager.php?sClass=version&iId=31794. I also ran it through Wine, not POL; its easier to get support that way in my opinion – Promille Oct 16 '15 at 11:42
  • 1
    First of all, thank you both for trying to help. @markkirby I did everything the user in your link explained, still no changes. – 110100100 Oct 16 '15 at 12:08
1

In case anyone has the same problem, I just wanted to say that I have found a solution here: https://www.playonlinux.com/en/topic-11344-1.html

Quote from the link:

"I just made these steps:

  1. Install in POL: d3dx10, d3dx11, d3dx9 (only d3dx9, not the other d3dx9_etc) and directx9
  2. It will broke your Adobe Air (already installed in wine), I really don't know why but it does it, so we have to fix, go to Configure Wine, then select the tab Libraries and add the lib "dnsapi" and set it to "integrate, native"
  3. Enjoy League Of Legends"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.