I've searched everywhere for hours and can't find the solution. Using Skylake i5-6500 with Asus 7170 motherboard, Ubuntu 15.04. I have been unable to get the intel graphics working, even by editing grub in the terminal with the i915 preliminary = 1 setting (I did type it correctly on the screen). I can't find how to fix this. I am using Gallium graphics now, it is the only thing that works. I also have an Nvidia gtx 950, I presume once intel HD graphics are working I can then install the Nvidia driver using root .sh on the downloaded file. If anyone can help I will personally offer to write a tutorial on how to fix it for other newbies. It seems thousands of people are having the same issue. Many, many thanks Tom

marked as duplicate by bain, Eric Carvalho, Pilot6, Charles Green, David Foerster Jan 29 '16 at 10:01

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Apparently, there isn't much support for Skylake in 15.04, which is not fixable. A known workaround is to add i915.preliminary_hw_support=1. Another workaround is to try Intel graphics installer (currently 1.2.0). – mikewhatever Oct 16 '15 at 10:50
  • Thanks, I have tried both but neither seem to work. Shall I just abandon the system for six months? I am so frustrated I feel like throwing it away :( I have just spent nearly £800 on it. I just don't know what to do. – Tom Nadia Oct 16 '15 at 12:03
  • I've installed Ubuntu 15.10 and now the Nvidia card is recognised (not the internal HD530). But at least I can use it :) – Tom Nadia Oct 23 '15 at 22:25

For Ubuntu 15.04 you will need to add these kernel commands to your grub configuration. i915.preliminary_hw_support=1 and also nouveau.modeset=0

I am unable to get Nvidia drivers working on 15.04.

On 15.10 I have yet to see Intel or Nvidia working for myself.

EDIT: On Ubuntu 15.04 I was able to get Nvidia graphics working. Leaving those kernel commands in place i installed via CLI nivida-346 nvidia-prime nvidia-settings, rebooted and everything worked.

Not the answer you're looking for? Browse other questions tagged or ask your own question.