I'm trying to enter a tab character in Firefox/Chrome text boxes without having to copy-paste from Emacs. The combination Ctrl+Shift+U then 0009 does not work. In fact, it does not seem to work for most "control" characters. However, it works for pretty much any printable character including non-ASCII. This is really bizarre. Google doesn't seem to reveal any such inconsistent behavior. Anyone know why this combination bans whitespace? I can repeat this behavior in any program including Leafpad and LibreOffice.

U+2023: ‣
U+0100: Ā
U+0009: (nothing)
U+000A: (nothing)
U+0020: (space)

  • 1
    Not that it helps particularily, but the problem is tied to your configuration, i.e. that's not something supposed to happen (I can insert all of those). I wouldn't know that to suggest though.
    – kos
    Oct 15, 2015 at 16:49
  • Thanks @kos. I actually made a breakthrough. I can type the tab character via that shortcut only as root! Not sure what's going on yet but I will keep investigating.
    – user461539
    Oct 23, 2015 at 2:19

1 Answer 1


Got it. The reason it was working as root and not my regular user was because the environment variables GTK_IM_MODULE and QT_IM_MODULE were being forced to xim for all regular users, regardless of runs of im-config. The only module I have installed under Lubuntu is ibus, so I'm not surprised by this strange behavior. A few articles on the net brought those variables to my attention so I started debugging around them. When I noticed they were being set to xim persistently, I decided to force them to ibus under /etc/environment. You have the less aggressive option of setting them in .bashrc or some equivalent. Regardless, this will restore full Ctrl+Shift+U functionality.

  • thank you! in my Linux Mint I was able to modify the input method from a GUI app (search for Input) and set it to none (instead of xim). To have it work I had to restart the X session (maybe that's why your im-config was ignored?). Jan 29, 2016 at 1:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.