17

I updated recently to phpstorm 9.5 and it says I should update ibus to 1.5.11 or newer (which at this point the current one).

Ok. I downloaded 1.5.11 from source and try to install it. I got some dependencies solved, but at one point I have a strange configuration error, that Package requirements (dconf >= 0.7.5) were not met.

after installing dconf-tools and other parts of the dconf package I still get this massage. Than I did sudo apt-cache show dconf-tools and found in the output that libdconf0 (<< 0.7.3-2) is causing problems, as libdconf1 is 0.20.0-1 which seems to be newer.

Assuming that on 14.04 libconfd0 is not used anymore this information is obsolete for the compiling ibus.

How can I solve this?

Edit 1:

  • installed dconf-tools, dconf-cli, dconf-editor as dconf package is not present in the packages.
  • checked the /etc directory there is dconf related stuff there
  • checked ibus/configure mechanism for dconf:

    if test x"$enable_dconf" = x"yes"; then
        # check dconf
        PKG_CHECK_MODULES(DCONF,
            [dconf >= 0.7.5],
        )
        PKG_CHECK_EXISTS([dconf >= 0.13.4],
            [AC_DEFINE(DCONF_0_13_4, TRUE, [dconf is 0.13.4 or later])],
            [])
        # check glib-compile-schemas
        GLIB_GSETTINGS
        enable_dconf="yes (enabled, use --disable-dconf to disable)"
    fi
    

Edit 2:

libdconf0 was misleading

15
  • as I could figure out, the libdconf0 assumption was misleading, checking the ibus configuration it simple uses PKG_CHECK_MODULES where I couldn't found any dconf.pc entries on my computer Oct 15, 2015 at 7:30
  • 1
    git or dconf, that makes no difference. Simply use checkinstall, therefore your question is a duplicate of Make dpkg to know compiled programs : git
    – A.B.
    Oct 15, 2015 at 7:57
  • I'm not sure how it helps with dconf Oct 15, 2015 at 8:58
  • still get No rule to make target `install' which means configure didn't run well of missing dconf which is not presence sudo apt-cache policy dconf Oct 15, 2015 at 9:21
  • 1
    Please edit your question and add what you have done. E.g. where you have downloaded the dconf source.
    – A.B.
    Oct 15, 2015 at 9:38

1 Answer 1

10

For proper IntelliJ integration I had to compile iBus 1.5.11 from source.

To succeed on this I had to install libdconf-dev and libnotify-dev, which libs where not properly mentioned by to original ibus maintainer so I suggested him to add this information for a successful build process description on Debian based systems.

sudo apt-get install libdconf-dev libnotify-dev
5

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .