0

I use a TOSHIBA Satellite A300 laptop with Windows 8.1 Pro installed.

I made a live USB using Universal USB Installer 1.9.6.1 from which I can boot Ubuntu 15.04 using the ISO image from Ubuntu website.

My laptop successfully booted from the USB memory and ubuntu successfully ran without trouble.

On the desktop (I suppose it's called desktop) there was a file/program with the name "Install Ubuntu 15.04," which I opened.

During the installation I chose a drive which I already had decided to allocate for Ubuntu and changed its filesystem type to ext4`` and installed Ubuntu onto this drive. When the installation finished I was asked to restart my computer, which I did but instead my computer directly booted my windows 8.1. The partition on which ubuntu is installed is now invisible to windows but it says "healthy" in the Disk Management tab in the computer management window of Windows 8.1 . I saw during the installation of ubuntu the status "Installing GRUB" or something similar, I did some research then found out that GRUB is a multiboot manager from FSF. However, it seems that it doesn't exist and I can't reach to boot Ubuntu installed on the HDD no matter what I do.

I'd like your help to know what I should do to:

  1. Make my computer detect Ubuntu so I can boot it.

  2. Ask each time for which OS I'd like to boot.

thank you very much

marked as duplicate by Eric Carvalho, Fabby, Zanna, Charles Green, David Foerster Aug 26 '17 at 8:39

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

I suppose the problem was that grub was installed and configured to run ubuntu only because I chose "something else" when installing ubuntu, since I had no important information I reinstalled ubuntu but this time I chose "install alongside windows", therefore grub was installed and configured to prompt for which OS to boot.

that's what I deduced trying to solve this problem.

I hope this was helpful.

0

First you have to disable hibernation and Fast Boot (if applicable) in your Windows 8.1 OS.
Boot into Windows, open command prompt as administrator and execute this command:

powercfg /h off  

To disable Fast Boot open Control Panel (the old version - not the modern design),
select the Energy Settings, enable show hidden settings and uncheck Fast Boot.

Shutdown the machine (do NOT reboot) completely.

Reinstall the GRUB bootloader to your Ubuntu installation in EFI mode.
Boot from the Ubuntu install media - then open a terminal and execute:

sudo mount /dev/sd*** /mnt
sudo mount /dev/sd** /mnt/boot/efi
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
sudo chroot /mnt
grub-install /dev/sd*
update-grub  

Note 1 : sd* = disk | sd** = efi partition | sd*** = system partition

In case your machine came with legacy BIOS - reinstall GRUB bootloader using these commands:

sudo mount /dev/sd** /mnt  
sudo grub-install --boot-directory=/mnt/boot /dev/sd*

Note 2 : sd* = disk | sd** = system partition

To identify the partition numbers use GParted. The tool is included in the Ubuntu install media.

Boot into BIOS and change the boot order in UEFI settings.
Select Ubuntu to be the default operating system to boot.
Now you can select which system to boot from GRUB menu.

Not the answer you're looking for? Browse other questions tagged or ask your own question.