1

So I installed simcity 3000 on kubuntu 15.10 beta 2 successfully with all the patches needed to make it run on such a recent distro. However, I can't get the sound to run.

Since the game still uses oss and I don't have I have '/dev/dsp' (which the game complained about), I installed the 'libpulse0:i386' and 'libpulsedsp:i386' packages. Edited padsp so it points to the rigth 32 bit library, but whenever I run simcity with './padsp ./sc3u.sh' I get:

ERROR: ld.so: object '/usr/lib/i386-linux-gnu/pulseaudio/libpulsedsp.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/usr/lib/i386-linux-gnu/pulseaudio/libpulsedsp.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
Running WITH lokicompat libs!
Inconsistency detected by ld.so: dynamic-link.h: 62: elf_get_dynamic_info: Assertion `! "bad dynamic tag"' failed!

If I run without editing the padsp (i.e. with it pointing to the 64 bit libraries) I get:

./sc3u: error while loading shared libraries: /usr/lib/x86_64-linux-gnu/pulseaudio/libpulsedsp.so: cannot open shared object file: No such file or directory

However I can do the following:

ls -l /usr/lib/x86_64-linux-gnu/pulseaudio/libpulsedsp.so 
-rw-r--r-- 1 root root 43728 Out 13 08:38 /usr/lib/x86_64-linux-gnu/pulseaudio/libpulsedsp.so

So, I don't know if the game doesn't find the 64 bit library or is incompatible. I think it is the latter, but I can't run with the 32 bit library either... Any ideas?

1

Solved it by installing the package osspd !!!!!!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.