3

I have run the Language Support tool and clicked Install/Remove Languages... and installed Irish. I can see from the Ubuntu Software Center that at least two packages are installed *-ga-base being one of them.

But Irish still doesn't appear on the list in the Language Support tool. Apparently, when I installed the language, there is supposed to be a + for more options, which is missing (and is a bug). (See the accepted answer here How to change system language? for more details)

How can I get languages other than just English on the list in Language Support?

Update: Running gnome-language-selector from the terminal I see this output:

gnome-language-selector:22702): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-iIuzZfldLm: Connection refused
[]
[<Package: name:'firefox-locale-ga' architecture='amd64' id:2712>, <Package: name:'language-pack-ga-base' architecture='amd64' id:2713>, <Package: name:'language-pack-gnome-ga-base' architecture='amd64' id:5653>, <Package: name:'language-pack-gnome-ga' architecture='amd64' id:5651>, <Package: name:'myspell-ga' architecture='amd64' id:1918>, <Package: name:'libreoffice-l10n-ga' architecture='amd64' id:11807>, <Package: name:'kde-l10n-ga' architecture='amd64' id:33666>, <Package: name:'language-pack-ga' architecture='amd64' id:5649>]

Other output:

$ /usr/share/language-tools/language-options 

en  en_AU  en_CA  en_GB  en_NZ  en_US

Output of locale -a:

$ locale -a
C
C.UTF-8
en_AG
en_AG.utf8
en_AU.utf8
en_BW.utf8
en_CA.utf8
en_DK.utf8
en_GB.utf8
en_HK.utf8
en_IE.utf8
en_IN
en_IN.utf8
en_NG
en_NG.utf8
en_NZ.utf8
en_PH.utf8
en_SG.utf8
en_US.utf8
en_ZA.utf8
en_ZM
en_ZM.utf8
en_ZW.utf8
POSIX

Running sudo apt-get install --reinstall language-pack-ga-base

Setting up language-pack-ga-base (1:14.04+20150804) ...
Generating locales...
  ga_IE.UTF-8... up-to-date
Generation complete.

And subsequently (I may have been ssh'd into the wrong machine first time!)

Generating locales...
  ga_IE.UTF-8... cannot open locale definition file `ga_IE': No such file   or directory
failed
Generation complete.
4
+50

The answer you refer to is about Ubuntu GNOME, but since you have Ubuntu, there is no "+" to look for.

As I mentioned in a reply to the bug comment you wrote, thie Irish option is labeled "Gaeilge" in the list.

Edit:

Please run these commands:

sudo mkdir /usr/share/locale-langpack/ga
sudo apt-get install $(check-language-support)

That ought to bring Gaeilge in.

Edit II:

Okay, the Gaeilge locale has apparently not been generated. As a next measure, I suggest that you run this command:

sudo apt-get install --reinstall language-pack-ga-base

If that succeeds, you may want to try this again:

sudo apt-get install $(check-language-support)

Edit III:

The failure when generating locales indicates that the locales package was incompletely installed. So let's redo that:

sudo apt-get install --reinstall locales
  • Gaeilge is listed in Language Support, not the Install/Remove dialog. And only if it has been successfully installed. First you must select 'Irish' from the Install/Remove Languages section. I am not getting Gaeilge on this machine though. I've added the console output to my original question. Hopefully it's revealing - and not beacuse I was ussing X forwarding from another machine. – TenLeftFingers Oct 17 '15 at 16:51
  • @TenLeftFingers: Let's find out the status: Can you please run /usr/share/language-tools/language-options and let us know the output. Also, does the command check-language-support result in any output? – Gunnar Hjalmarsson Oct 17 '15 at 20:18
  • Thanks Gunnar. The second command returns nothing, but the first shows output. Question updated again :) – TenLeftFingers Oct 17 '15 at 20:44
  • @TenLeftFingers: Ok, the problem you are having with installing via Language Support is over my head - something with dbus. But I edited my answer with a couple of suggested commands. – Gunnar Hjalmarsson Oct 17 '15 at 20:51
  • @TenLeftFingers: Did those commands solve the problem? – Gunnar Hjalmarsson Oct 20 '15 at 1:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.