1

I tried to follow the instructions here: Why does a Ubuntu guest in VirtualBox run very, very slowly?

However, I cannot get sudo ./VBoxLinuxAdditions.run to work as it says ./VBoxLinuxAdditions.run not found, even though I already tried sudo apt-get install virtualbox-guest-utils and restarted. And when I type /usr/lib/nux/unity_support_test -p, it still says Utiliy 3D is not supported and a bunch of lines with OpenGL warning: [..] not found in mesa table. What is going on?

  • So be able to install the guest addition we need to mount the CD/ISO first, then cd to the (mounted) disk image to then run the installer script as root. Also see askubuntu.com/questions/22743/… – Takkat Oct 15 '15 at 7:04
  • I followed the instructions there, and I think Guest Additions was installed successfully so I rebooted,however I'm having problems at Note 2. Even though I cd /usr/share/virtualbox/ and when I ls I see the VBoxGuestAdditions.iso, when I sudo ./VBoxLinuxAdditions.run, it keeps saying ./VBoxLinuxAdditions.run command not found – ske Oct 15 '15 at 7:53
  • You have to mount that ISO in the virtual machine. Only then you will be able to run the guest additions installer script from the guest Ubuntu. – Takkat Oct 15 '15 at 8:04
  • ok, I was able to run sudo ./VBoxLinuxAdditions.run and after rebooting, VirtualBox is now much faster than before, although it is still too slow and barely tolerable. I then typed /usr/lib/nux/unity_support_test -p, but I still see Unity 3d supported: no. why is this?! I see under settings ->display that 3d acceleration is still clicked – ske Oct 15 '15 at 9:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.