I'm a linux newbie and ran into this problem when trying to install Ubuntu as dual-boot with my Windows 10. I've done that before with Windows 7, with wubi. But I read that wubi wasn't the preferred instalation method anymore, so I tried with a bootable USB drive.

I've put the 14.04.3 Ubuntu image into the USB drive, then installed it on my laptop selecting the "Install alongside Windows 8" option. Everything went fine, but when I restarted it booted directly into Ubuntu (instead of the grub screen where I can get to choose which OS to use).

Googling about this, I saw some solutions that worked for people in similar situations. Tried the "Recommended Repair" option on the Boot Repair tool, with no success except that now the Grub screen appears (though with no "Windows 10" option). Also tried sudo update-grub but no changes.

Some info that may help:

  • I can't see my windows partitions on Nautilus.
  • I have a laptop with an 1tb HD with two partitions:
    • C:\ - named SYSTEM, with ~200gb for Windows 10 (upgraded from 8.1)
    • E:\ - named COPA, with ~700gb for personal files
  • With TestDisk, I was able to find both C:\ and E:.
  • Ran Boot Info Script and got this result.
  • Here's a screenshot from GParted

Thanks in advance for anyone that can help me with this! :)

  • Is your PC UEFI or legacy BIOS? Try both of these things: 1. Boot into Windows, go into "Power Options", then "Choose what the power buttons do". Click "Change settings that are currently unavailable" and then disable "Fast Startup (recommended)". 2. Run Chkdsk – Aaron Franke Sep 11 '16 at 8:18

The default installation of windows 10 requires a minimum of 4 partitions:

  1. sda1 (Recovery)
  2. sda2 (Boot/efi)
  3. sda3 (MSR)
  4. sda4 (Windows OS, usually "C")

If the "boot/efi" partition or the "MSR" partition has been damaged or deleted during the ubuntu install you might not be able to see windows in grub. Try the following command in ubuntu to see all the available partition:


It should give you an idea of what happened to your system. From the screenshot you've provided it seems that all the partition are there. You might try to repair windows with the installation CD/USB.

You can try to instal Grub customizer and see if windows is available in the list:

sudo add-apt-repository ppa:danielrichter2007/grub-customizer
sudo apt-get update
sudo apt-get install grub-customizer

To launch: "Applications > System Tools > Grub Customizer" then you can change which system are available to boot.

Here's a screen of what a correct installation looks like: Screenshot:

Hope this helps!


  • I checked the screenshot again, the MSR partition is in fact there. The one with the "msftres" flag. – itSp4x Oct 14 '15 at 18:23
  • Thanks for the response! I've ran the lslbk command and got me this: paste.ubuntu.com/12783523 which is pretty much what you said :) I've also installed Grub Customizer but windows isn't available there either. Now I'll look into trying to repair windows with the installation USB. I'll give an update once I get to try. – Ronaldo Vieira Oct 14 '15 at 19:12
  • Updating: Tried to repair windows initialization with the USB but it said it couldn't repair. Then used bootrec on cmd and it didn't recognize any windows installation. Now not even grub works, but I guess that was expected. – Ronaldo Vieira Oct 14 '15 at 21:20
  • If nothing works at this point you'll probably have to create a live USB and backup your DATA then reinstall. I usually don't use install alongside windows and will partition the disk myself to make sure nothing important gets deleted. – itSp4x Oct 14 '15 at 21:23
  • You might wanna run a checkdisk or something, maybe your hard drive is defective. Even if some partition were missing you should still be able to access the Windows partition with Nautilus. – itSp4x Oct 14 '15 at 21:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.