3
Xubuntu 14.04.3
Thinkpad t450s
Mpow Swift headset
$ bluetoothd -v
4.101
$ pulseaudio -v
4.0

A2DP was working (after following other threads to tweak the /etc/bluetooth/audio.conf file). I was able to disconnect and reconnect my headset previously. I would have to manually select A2DP instead of HFP/HSP, but it would work. I didn't change any versions or run a system update, but something happened because now it's not doing anything when I select A2DP. If 'Off' is selected, then selecting A2DP will result in no audio. If 'HFP/HSP' is selected, then selecting A2DP will result in still HFP/HSP output.

Does anyone have a working setup to post their audio.conf, or any other files/settings, so I can match up what I have?

Is there a setting to have it select A2DP by default?

Thanks in advance!

Here's my audio.conf. (I've tried enabling Socket - same result. I tried enabling HFP - same result.)

$ sudo cat /etc/bluetooth/audio.conf
# Configuration file for the audio service

# This section contains options which are not specific to any
# particular interface
[General]

# Switch to master role for incoming connections (defaults to true)
#Master=true

# If we want to disable support for specific services
# Defaults to supporting all implemented services
#Disable=Gateway,Source,Socket
#Enable=Gateway,Source
Enable=Source,Sink,Headset,Gateway,Control,Media
Disable=Socket

# SCO routing. Either PCM or HCI (in which case audio is routed to/from ALSA)
# Defaults to HCI
#SCORouting=PCM

# Automatically connect both A2DP and HFP/HSP profiles for incoming
# connections. Some headsets that support both profiles will only connect the
# other one automatically so the default setting of true is usually a good
# idea.
AutoConnect=true

# Headset interface specific options (i.e. options which affect how the audio
# service interacts with remote headset devices)
[Headset]

# Set to true to support HFP, false means only HSP is supported
# Defaults to true
HFP=false

# Maximum number of connected HSP/HFP devices per adapter. Defaults to 1
MaxConnected=1

# Set to true to enable use of fast connectable mode (faster page scanning)
# for HFP when incoming call starts. Default settings are restored after
# call is answered or rejected. Page scan interval is much shorter and page
# scan type changed to interlaced. Such allows faster connection initiated
# by a headset.
FastConnectable=false

# Just an example of potential config options for the other interfaces
[A2DP]
SBCSources=1
MPEG12Sources=0
0

Ok, so I tried changing to disable Headset and that killed it completely. The selections would just have (unplugged) after them so no audio would output:

Enable=Source,Sink,Gateway,Control,Media
Disable=Socket,Headset

$ sudo service bluetooth restart 
bluetooth stop/waiting
bluetooth start/running, process 8552
$ sudo alsa force-reload
Unloading ALSA sound driver modules: snd-seq-midi snd-seq-midi-event snd-seq snd-rawmidi snd-seq-device snd-hda-codec-hdmi snd-hda-codec-realtek snd-hda-codec-generic snd-hda-intel snd-hda-controller snd-hda-codec snd-hwdep snd-pcm snd-timer (failed: modules still loaded: snd-hda-codec-hdmi snd-hda-codec-realtek snd-hda-codec-generic snd-hda-intel snd-hda-controller snd-hda-codec snd-hwdep snd-pcm snd-timer).
Loading ALSA sound driver modules: snd-seq-midi snd-seq-midi-event snd-seq snd-rawmidi snd-seq-device snd-hda-codec-hdmi snd-hda-codec-realtek snd-hda-codec-generic snd-hda-intel snd-hda-controller snd-hda-codec snd-hwdep snd-pcm snd-timer.
$ pulseaudio -k

So then I put it back and it started working again:

Enable=Source,Sink,Gateway,Control,Media,Headset
Disable=Socket

$ sudo service bluetooth restart 
bluetooth stop/waiting
bluetooth start/running, process 15071

How that makes sense I don't know. Sometimes linux is the worst!

  • It was doing it again after being in suspended mode. I tried to just restart the bluetooth service and this time it worked with just that. sudo service bluetooth restart – Chip Oct 14 '15 at 22:42
  • It's off and on working or not. These steps are now not fixing it. So it's random when it wants to work and when it doesn't. – Chip Oct 16 '15 at 20:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.