1

libgluezilla doesn't seem to be available anymore. This breaks a few Mono apps on Ubuntu.

Where can I get it? libmono-webbrowser4.0-cil is installed, but it doesn't install libgluezilla.

2

The latest version was for Lucid, but you can install the package also in Vivid with some aditionally packages.

  • Download the Lucid version of libgluezilla_2.4.3-2

    • 32-bit

      cd; wget http://security.ubuntu.com/ubuntu/pool/main/g/gluezilla/libgluezilla_2.4.3-2_i386.deb
      

      OR

    • 64-bit

      cd; wget http://security.ubuntu.com/ubuntu/pool/main/g/gluezilla/libgluezilla_2.4.3-2_amd64.deb
      
  • Download xulrunner-1.9.2

    • 32-bit

      cd; wget http://security.ubuntu.com/ubuntu/pool/main/x/xulrunner-1.9.2/xulrunner-1.9.2_1.9.2.28+build1+nobinonly-0ubuntu0.10.04.1_i386.deb
      

      OR

    • 64-bit

      cd; wget http://security.ubuntu.com/ubuntu/pool/main/x/xulrunner-1.9.2/xulrunner-1.9.2_1.9.2.28+build1+nobinonly-0ubuntu0.10.04.1_amd64.deb
      
  • Download libhunspell-1.2-0

    • 32-bit

      cd; wget http://security.ubuntu.com/ubuntu/pool/main/h/hunspell/libhunspell-1.2-0_1.2.8-6ubuntu1_i386.deb
      

      OR

    • 64-bit

      cd; wget http://security.ubuntu.com/ubuntu/pool/main/h/hunspell/libhunspell-1.2-0_1.2.8-6ubuntu1_amd64.deb
      
  • Install dependencies available in the repositories (perhaps more depends on your current installation)

    sudo apt-get install libnspr4-0d libidl0 libnss3-1d
    
  • Install

    • 32-bit

      sudo dpkg -i libgluezilla_2.4.3-2_i386.deb xulrunner-1.9.2_1.9.2.28+build1+nobinonly-0ubuntu0.10.04.1_i386.deb libhunspell-1.2-0_1.2.8-6ubuntu1_i386.deb
      

      OR

    • 64-bit

      sudo dpkg -i libgluezilla_2.4.3-2_amd64.deb xulrunner-1.9.2_1.9.2.28+build1+nobinonly-0ubuntu0.10.04.1_amd64.deb libhunspell-1.2-0_1.2.8-6ubuntu1_amd64.deb
      

Tested in my Vivid system

% lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 15.04
Release:    15.04
Codename:   vivid

% apt-cache policy libgluezilla 
libgluezilla:
  Installed: 2.4.3-2
  Candidate: 2.4.3-2
  Version table:
 *** 2.4.3-2 0
        100 /var/lib/dpkg/status
6
  • Your last command is missing the 'l' for lib...
    – Climax
    Oct 14 '15 at 10:01
  • libidl0 and libnss3-1d was also needed
    – Climax
    Oct 14 '15 at 10:01
  • I got a SIGSEGV, but the packages installed successfully. I guess the libc and some others may have changed since lucid.
    – Climax
    Oct 14 '15 at 10:03
  • that's not really fair. your question has been answered. for new problems you should ask a new question.
    – A.B.
    Oct 14 '15 at 10:50
  • I believe your solution to installing the package is pointless if it doesn't work. The question is specifically for Vivid so the package should be functional there as well.
    – Climax
    Oct 14 '15 at 10:52
1

The solution provided by A.B. works fine for 16.04.2 but note that when installing the libidl0 using apt-get, it will require libidl-2-0. A solution to install libidl0 on Ubuntu 16.04 is here: Unable to install Kompozer in Ubuntu 16.04 After libidl0 is installed. Follow A.B.'s steps and it works!!

For 14.04, it seems it does not work as the xulrunner cannot be installed. Still figuring out how it can be done correctly.

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 16.04.2 LTS
Release:    16.04
Codename:   xenial

$ apt-cache policy libgluezillalibgluezilla:
  Installed: 2.4.3-2
  Candidate: 2.4.3-2
  Version table:
 *** 2.4.3-2 100
        100 /var/lib/dpkg/status

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.