0

I am trying to hook up two monitors to my Ubuntu 14.04.3 desktop. My First monitor is connected to the CPU via an RS-232 cable, and is up and running. The second monitor is connected to a display link adapter, whose other end is a USB connection to the CPU. When I boot up, I see some startup messages on the second monitor, but when the first monitor's login loads, the second monitor crashes once I login to the first monitor.

These are my specs:

foo@bar ~ $ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.3 LTS
Release:    14.04
Codename:   trusty

foo@bar ~ $ uname -r
3.16.0-50-generic
foo@bar ~ $ 

foo@bar ~ $ lsusb
Bus 002 Device 003: ID 046d:c05a Logitech, Inc. M90/M100 Optical Mouse
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 413c:2107 Dell Computer Corp. 
Bus 003 Device 004: ID 17e9:019a DisplayLink 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
foo@bar ~ $ 

foo@bar ~ $ xrandr --query  
Screen 0: minimum 8 x 8, current 1920 x 1200, maximum 16384 x 16384
DVI-I-0 connected primary 1920x1200+0+0 (normal left inverted right x axis y axis) 518mm x 324mm
   1920x1200      60.0*+
   1920x1080      60.0  
   1680x1050      60.0  
   1600x1200      60.0  
   1280x1024      60.0  
   1280x960       60.0  
   1024x768       60.0  
   800x600        60.3  
   640x480        59.9  
DVI-I-1 disconnected (normal left inverted right x axis y axis)
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)

~ $ lspci -vnn | grep -i VGA -A 12
02:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK107GL [Quadro K600] [10de:0ffa] (rev a1) (prog-if 00 [VGA controller])
    Subsystem: NVIDIA Corporation Device [10de:094b]
    Flags: bus master, fast devsel, latency 0, IRQ 82
    Memory at fa000000 (32-bit, non-prefetchable) [size=16M]
    Memory at e0000000 (64-bit, prefetchable) [size=256M]
    Memory at f0000000 (64-bit, prefetchable) [size=32M]
    I/O ports at e000 [size=128]
    [virtual] Expansion ROM at fb000000 [disabled] [size=512K]
    Capabilities: <access denied>
    Kernel driver in use: nvidia

02:00.1 Audio device [0403]: NVIDIA Corporation GK107 HDMI Audio Controller [10de:0e1b] (rev a1)
    Subsystem: NVIDIA Corporation Device [10de:094b]

 ~ $ sudo lshw -C video
  *-display               
       description: VGA compatible controller
       product: GK107GL [Quadro K600]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:82 memory:fa000000-faffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:fb000000-fb07ffff

I have tried various posts on getting the second monitor to work, butnone have worked. I also tried switching the second monitor to use the RS32 cable directly while connecting the first monitor to the display link adapter, which caused the second to start working and first to show a black screen. The detect displays from the settings did not work either.

  • you second monitor setup is not standard and will cause issue with display manager to read your monitor information. – Aizuddin Zali Oct 14 '15 at 5:18
  • How do you know it is not standard? How can I fix it? – shank22 Oct 14 '15 at 17:06
  • Standard setup will not have intermediate between connection. Computer monitor are not 100% like TV. – Aizuddin Zali Oct 14 '15 at 17:24
  • Please answer the question if possible and provide a solution. – shank22 Oct 14 '15 at 17:26
  • Use one display card per session. – Aizuddin Zali Oct 14 '15 at 18:02
0

I was able to get the two monitors working by using a DVI to Display cable and adapter, instead of the DisplayLink USB adapter. I also upgraded my Ubuntu to the latest version. I am pretty sure the issue as with the DisplayLink adapter.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.