0

I am an old Windows guy trying to become a Linux guy. Im moving all the design and prep software for my 3d printers from windows to Ubuntu. I am really struggling trying to figure out how to get Slic3r to run. I downloaded the tar from github for the 32 bit ubuntu, extracted it into a folder at ~/Programs/Slic3r. This created several directories, including the bin directory holding the executable. But for me, it will not execute. I suspect I have left out one or more steps but am to Ubuntu challenged to know what they are. I've tried to find things on the web that would instruct me, but they all seem to confuse me more than anything.

Two questions... Is there a simple straightforward set of instructions for installing and running Slic3r?

Is here a particular log that I should be looking at that might tell me what (does not) happen when I right click on the Slic3r executable and select run. Nothing happens as far as I can see.

As always, any help would be appreciated.

  • tarballs are source files. I'm pretty sure they need to be installed. Read here: askubuntu.com/questions/191390/… – TheWanderer Oct 13 '15 at 23:59
  • yes, I have done that... – Charlie RC Oct 15 '15 at 13:35
  • cd Downloads tar -xzf slic3r-linux-x86-1-2-9-stable.tar.gz It did extract the files into directories, and put the executable in the bin folder of that structure. I tried clicking on the Slic3r icon, tried right clicking and pressing Run,...nothing happens in either case. I am very new to linux, so I am certain I am doing something wrong, but just don't know what. – Charlie RC Oct 15 '15 at 13:42
  • You need to run some other commands to actually install it. Stuff like ./configure. Did you follow the whole answer? – TheWanderer Oct 15 '15 at 14:45
  • Zacharee1: I have tried to follow the instructions as closely as I can. I have started over a few time now thinking I must have done something wrong. i run tar on the tar.gz file and it seems to unpack the tar. In the instruction it says next to run ./configure and that tells me no such file or directory....I tried skipping ahead to make but same result. I am completely lost here. – Charlie RC Oct 16 '15 at 20:46
0

I don't know why, but a fresh day brought a fresh try at following the instructions on Slic3r.org, and this time I must have done it right. Slic3r installed fine this morning. I don't have a clue what I was doing wrong that I finally did right.

| improve this answer | |
0

i had a problem when i installed slic3r earlier but after hours of searching for a solution i thought it was over. Then i tried to installed one more time and i got the same problem as i had before. i was stuck when i used this command CPANM=~/perl5/perlbrew/bin/cpanm perl Build.PL. it was just alot of red text showing. but on top of all that red text i saw the solution. cpanm --local-lib=~/perl5 local::lib && eval $(perl -I ~/perl5/lib/perl5/ -Mlocal::lib) and after i typed that in the terminal it worked! (you have to type sudo first tho. )

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.