1

I want to make my lubuntu look like Windows 8.1/10 (just for fun). I've installed WinAte icon set and it's window border theme. Since there was no widget them available in the pack I've installed "One more flat" for the widgets. It works perfect for many programs but all Gnome apps look like that:

Software updates PL

These dashed frames are almost everywhere. How do I fix that ?

  • Is the problem that it's in a different language or the dotted lines? – Eric Power Oct 21 '15 at 0:25
  • It's about lines. Language is correct. – pvc Oct 21 '15 at 12:07
  • 1
    Try this answer askubuntu.com/a/656405/367165 – A.B. Oct 21 '15 at 13:08
2
+50

If we are talking about this theme, it seems that it was last updated 2 years ago. In that time frame, much has changed in the way GTK3 draws it's themes. These dashed lines seem to be a side effect of out-of-date CSS.

The bad news is - the theme seems to be out of date, and will not render correctly in recent GTK.

The good news is, you can look at how other themes have handled this (example with vertex theme) and try to fix it yourself. You can find the reference guide here. You just need to handle the GTK3 related stuff, which should not be that much code. I know it's probably not the answer you were looking for, but AFAIK it's the only change you have to get it to work correctly.

The same is valid if the problem is in the One more flat theme.

Good luck trying to modernize the theme. I wouldn't say it's the easiest task in the world, but it shouldn't be the toughest one either. Especially if you are already familiar with GTK theme file locations. Bonus points if you are already familiar with CSS.

  • I think I will try to modernize them, so I could learn more about this matter. This answer gave me some idea of what is going on here but I will not accept it, for now, since maybe someone can point the problem directly. – pvc Oct 21 '15 at 16:55
  • Fair enough. If sombody has a better solution I'd be interested in it too. – Stunts Oct 21 '15 at 19:27
  • Success! I've installed gnome-tweak-tool which conveniently displays all CSS related problems on startup. The problem was weird, because these frames were explicitly enabled in gtk3/gtk-common.css. Why? Who knows... But after commenting out all outline-* properties in the main block, everything looks as expected now. – pvc Oct 22 '15 at 10:12
  • Cool! Have you considered opening a pull request for the original theme? _-) – Stunts Oct 22 '15 at 14:16
  • I am not really familiar with developing open source software and I can't find One more flat theme on GitHub. So I think I will leave it as it is. – pvc Oct 22 '15 at 16:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.