I'm still fairly new to linux and find myself making annoying noob mistakes. Yet, still loving the experience so what does that really say about me?

I ran into an interesting problem that I'm not sure how to correct. I was trying to upgrade my nodejs through npm and began running into a series of problems. However, the one that got me stuck is a segmentation error when using the node command. Nodejs works fine (nodejs - v returns v 0.12.7).

I need to mention that the node command worked fine until I followed one step too many from a forum post and didn't realize what I had done until I hit enter. (How can I update my nodeJS to the latest version?)

I created a symbiotic link using -> sudo ln -sf /usr/local/n/versions/node//bin/node /usr/bin/node. This was a step not needed as the installer had already taken care of all this.

I tried reversing my steps and have tried to remove nodejs and npm to the best of my ability and then reinstalling. I was able to reinstall just fine and upgrade but still unable to get the node terminal command to work properly.

I have been looking for how to correct a segmentation fault but keep finding explanations as to what a segmentation fault is and isn't very useful to me as my problem isn't a lack of understanding of the error but lack of understanding of the linux environment and not entirely sure how to go about fixing this problem without causing me errors.

If anyone could shed some light as to possible steps one could take to correct this type of error it would be a HUGE help.

And no this is not a nodejs question it just so happens that's the program I did it to. lol

It's not a huge deal but I'm trying to install the nodejs driver for mongodb and when using npm its looking for the node command and causing an error during install.

Thanks in advance to anyone who can help me out.

1 Answer 1


Okay so... I'm dumb. Thanks for listening guys. lol

Basically, all I had to do was run sudo n 0.12.7 to tell it which version to install.

I get the feeling there's a huge mess of things if I start looking at what's been installed more than once but its working for now. I'll do a clean Ubuntu install soon and start again from scratch without all my mistakes.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .