7

Question is simple: what starts the accounts service daemon on Ubuntu 14.04?

root     11495     1  0 13:55 ?        00:00:00 /usr/lib/accountsservice/accounts-daemon

pstree tells me that it's started by init

init-+-ModemManager---2*[{ModemManager}]
     |-NetworkManager-+-dhclient
     |                |-dnsmasq
     |                `-3*[{NetworkManager}]
     |-accounts-daemon---2*[{accounts-daemon}]

But when I do sudo grep -iR 'accounts-daemon' /etc/* it returns nothing, so obviously there is nothing in /etc/init or /etc/init.d or /etc/rc*.d directories that starts that daemon, hence the question, where is it ?

My main goal is to disable autostart of the accounts services daemon on boot.

8
  • First observation: Very high PID, therefore it may be something later in bootup. Perhaps a script in init.d calls something else which calls the daemon?
    – Daniel
    Oct 13 '15 at 22:00
  • If you just want to disable it, track it down and change the executable filename
    – Daniel
    Oct 13 '15 at 22:01
  • And maybe replace it with a simple false.
    – Daniel
    Oct 13 '15 at 22:01
  • @Daniel well, I considered disabling the filename, but i would like to do it the clean, honest way. Also, it's quite possible it's a chain of scripts, but at least it's nowhere in the /etc folder Oct 13 '15 at 22:04
  • I would at least try changing the filename, because if nothing else you could see what errors get thrown. Whatever calls it should complain about not finding it
    – Daniel
    Oct 13 '15 at 22:06
5

It's a DBUS service.

root@user-VirtualBox:~# grep -ir accounts-daemon /usr /etc
Binary file /usr/lib/accountsservice/accounts-daemon matches
/usr/share/dbus-1/system-services/org.freedesktop.Accounts.service:Exec=/usr/lib/accountsservice/accounts-daemon

Another way:

root@user-VirtualBox:~# dpkg -S /usr/lib/accountsservice/accounts-daemon
accountsservice: /usr/lib/accountsservice/accounts-daemon

root@user-VirtualBox:~# dpkg -L accountsservice
/.
/usr
/usr/share
/usr/share/dbus-1
/usr/share/dbus-1/system-services
/usr/share/dbus-1/system-services/org.freedesktop.Accounts.service
/usr/share/dbus-1/interfaces
/usr/share/dbus-1/interfaces/org.freedesktop.Accounts.xml
/usr/share/dbus-1/interfaces/org.freedesktop.Accounts.User.xml
...

To disable it, rename DBUS service file:

sudo mv /usr/share/dbus-1/system-services/org.freedesktop.Accounts.service /usr/share/dbus-1/system-services/org.freedesktop.Accounts.service.disabled
1
  • 1
    Does the job, after reboot no process accounts-daemon. Thank you very much ! Oct 16 '15 at 1:49
2

Yet another way...

To get the filename:

$ ps aux | grep -i accounts-daemon
root       718  5.6  0.7 398588 121280 ?       Rsl  Jan11 151:58 /usr/lib/accountsservice/accounts-daemon

Stop it and remove accountsservice package by running:

sudo service accounts-daemon stop
sudo apt remove accountsservice

It will also remove package user-manager, but do not worry about it :)

Additional info:

Package: accountsservice
Description: query and manipulate user account information
Package: user-manager
Description: user management tool for the Plasma workspace
1
  • This worked for me, saving around 1G RAM and 100% CPU from a 2 CPU machine. Thanks! Feb 24 '21 at 19:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.