I've tried several approaches and it still boots directly to Windows 10. It is a Toshiba Satellite Radius L15W-B1208X with Windows 10 the original OS.

I read and tried to follow all prerequisite steps in this helpful information-packed answer, and first tried Ubuntu 14.14 LTS, which installed but showed no dual boot menu.

Various answers and sources such as this one have suggested I could then tell the UEFI to start with Grub 2, but I see no such option. This Toshiba's UEFI config menu has never shown anything but the hard drive and USB as boot sequence options. The only other relevant setting seems to be Safe Boot on/off, which has never seemed to have any effect on behavior at any point in the hours and hours (and more hours) of trying things I have done. There is no "boot mode" option as suggested here - I suppose it is UEFI-only (no legacy option)?

The info-packed answerer said 15.04 has always just worked for him, so although I would prefer LTS, I tried Ubuntu 15.04, telling it to replace the 14.14 installation, and it is installed, but is equally unbootable.

I saw the suggestion that Toshiba may be violating the UEFI standard and annoyingly testing for "windows" in the file name and that I could rename the Linux bootloader to windows... but I don't know how to access the EFI partition - I assume I'd need to know how to find and mount it in Linux? I didn't see complete enough directions for my familiarity level, so I didn't try that.

Following advice on the WindowsDualBoot page of the Documentation section of the Ubuntu web site, I tried using a EasyBCD and managed to wipe my BCD making Windows 10 unbootable but I actually managed to fix that thanks in part to Toshiba's recovery system.

The most recent thing I've tried is Linux Boot-Repair, which I ran in all its steps but it had no visible effect. Its docs say the final steps should be to show its output data to my favorite help source, so here I am, and here they are.

Any suggestions?

2 Answers 2


Some observations from your Boot Repair output:

  • There are three sets of efibootmgr outputs, at 607-626, 1094-1109, and 1142-1157. It looks as if your system started up with the Ubuntu entries present but not listed in the boot order and Boot Repair tried to set one of these (Boot0004) as the default boot entry, but presumably that failed. This suggests a bug in either your EFI or in efibootmgr.
  • There are a number of efibootmgr errors that read efibootmgr: Could not delete boot variable: No such file or directory. This also suggests a bug in either your firmware or in efibootmgr.
  • There are a lot of duplicate NVRAM entries shown by efibootmgr, especially in its first run, which has duplicate entries for both Windows and Ubuntu. This suggests EFI bugs rather than efibootmgr bugs, since presumably something in Windows created multiple entries for some reason (which it might have done if it thought its entries were not being created).

Overall, this looks like buggy firmware to me. You can check with your manufacturer to see if an update is available. If so, install it and try Boot Repair again. If that fails, you may still be able to work around it. First, try Windows. There are two things you might attempt:

  • Download EasyUEFI and use it to adjust the boot order. This tool is pretty easy to use; just move the "Ubuntu" entry to the top of the list. If there are multiple entries, move one that refers to shimx64.efi, not one that refers to grubx64.efi.
  • Open an Administrator Command Prompt window (not the newer shell in Windows 10; the older classic Command Prompt) and type bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi.

If these procedures both fail, you could try using an EFI shell and its bcfg command, as described here. Note, however, that you'll need to disable Secure Boot to get the EFI shell to launch, and you'll need to copy the shell program to a USB flash drive as EFI/BOOT/bootx64.efi, then boot that drive.

If all of this fails, I recommend you return the computer for a refund, on the grounds that its firmware is badly defective. If you do this, be sure to write to the manufacturer to say that you returned the product and why. It's only if manufacturers feel the pain of returns that they'll be motivated to fix their defective firmware. Dell, ASUS, Lenovo, and Apple deliver fairly usable EFIs. Sony and HP seem to be less reliable, judging by problem reports I've seen. I can't comment on other brands.

If you can't return the computer, you can try the Advanced tab of Boot Repair, which includes an option to rename and back up boot loader files. This places GRUB under the name of the Windows boot loader, which is an ugly and unreliable hack of a workaround for an ugly bug. I recommend doing this only as a last resort; it's far better to return a computer with firmware defective enough to need this sort of workaround.

  • Is UEFI is most current version from Toshiba, many Toshiba's seem to work with the copy /EFI/ubuntu to /EFI/boot and rename shimx64.efi to bootx64.efi. Details: askubuntu.com/questions/486752/… To houseclean extra UEFI entries: askubuntu.com/questions/63610/…
    – oldfred
    Oct 14, 2015 at 23:46
  • Thank you so much for this attention, as I have little idea how this is supposed to work or what to do about it. However I think I likely know what the multiple Windows and Linux entries are from: When I was trying to get EasyBCD, before I cleared the BCD, I tried its other options, which had it creating multiple entries. These would cause a non-grub boot menu to appear on startup, but the Linux entry would always just say there was an error and refuse to actually run Linux. Maybe those could be cruft left over from having done that? (I will have time to try your two suggestions tomorrow PM).
    – Dronz
    Oct 14, 2015 at 23:54
  • oldfred, IMHO, if any modern computer requires the ugly workaround you suggest, it should be returned to the manufacturer as defective, because that's what it is. Renaming boot files is not a solution; it's a workaround. As a practical matter, of course, returning a comptuer for a refund is not always possible because of limited return periods.
    – Rod Smith
    Oct 15, 2015 at 12:56
  • @RodSmith EasyUEFI shows only one entry: "EFI USB Device" in its Boot order list, I used its Create New Entry screen to make an Ubuntu entry pointing at shimx64.efi in the first partition, which seemed to be the only thing I could do. I shut down and restarted, but it just went straight to Windows. Then I tried also adding an entry for Windows and putting it lower than Ubuntu, but again it went straight to Windows. I'm about to try the bcdedit suggestion.
    – Dronz
    Oct 16, 2015 at 23:23
  • @RodSmith FYI, BCDEdit and moving Linux to position 0 using EFI shell also failed to do anything but start with Windows (man, I am getting angrier and angrier at Windows 10 every time it comes up). I'm going to try the Advanced tab on Boot Repair.
    – Dronz
    Oct 16, 2015 at 23:58

After updating the Bios from version 1.20 to 5.0 I was able to boot into Linux mint 17.3 x64. I downloaded the bios, burned it to a CD, booted from it and typed UBIOS at the prompt to perform the Bios update.

Now when I boot the machine have 4 options:

  1. Linux Mint 17.3 Cinnamon 64-bit
  2. Advanced options for Linux Mint 17.3 Cinnamon 64-bit
  3. Windows Boot Manager (on /dev/sda2)
  4. *System setup

First option will boot into Linux Mint and 3rd into Windows 10 x64 (my running version of Windows)

Here's the link for the Bios download: http://support.toshiba.com/support/modelHome?freeText=PSKVUU-00J01M

  • Awesome! I will have to try that out once I get the computer back to work on! Were you having the same kinds of problems before the BIOS update? And after the BIOS update, what did you do to load Mint?
    – Dronz
    Feb 15, 2016 at 6:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .