7

My laptop used to have windows 7 which I had upgraded to windows 8.1 and then to windows 10 and along with them I used to have ubuntu. The disk partitions used to look like ([System Reserved], [recovery partition provided by dell], C [windows boot], E [documents, music and stuff], [swap], [ubuntu]). Whenever I ran in a problem and had to reinstall ubuntu, I would do so using the something else option (create swap and / partition, both logical partitions).

My hard disk crashed a few days ago and I had to replace it. So I installed windows 7 on it again and then upgraded to windows 10. Now I'm trying to install ubuntu like I always did. But this time the disk space I leave for ubuntu is showing up as unusable in the setup. Windows has created a 450MB recovery partition this time and so (I think) the extra space which used to be marked 'free space' in disk management is now marked as unallocated (and so showing up as unusable in ubuntu setup). The partitions look like this: ([System reserved], C, [unnamed Recovery Partition], E [documents and stuff], [unallocated]) [System reserved]: System, Active, Primary Partition C: Boot, Page File, Crash Dump, Primary Partition E: Primary partition

I have no idea how the recovery partition got created. Although googling it suggests that it is something new with win 8 and 10, it never got created on my old hard disk. There is no option to delete the recovery partition, right clicking it in disk management gives only a help option which links to a page for disk management. So any solutions?

Edit: I just remembered that when I did not have ubuntu installed, the E partition and free space, as a whole, would show up as extended partition in disk management, which is no more the case.

  • You could maybe try creating the partitions from disk manager? – Wilhelm Erasmus Oct 13 '15 at 20:57
  • Is it a program available on net? Can you provide a link? – Mihir Gadgil Oct 14 '15 at 3:19
  • I mean like the program included with Windows – Wilhelm Erasmus Oct 14 '15 at 4:02
  • Thanks for your reply, but I solved the problem on my own. Should I mark the post for deletion or post my solution here and mark it as answer? – Mihir Gadgil Oct 14 '15 at 6:25
  • Post the solution and mark answer. It might be useful to others – Wilhelm Erasmus Oct 14 '15 at 10:03
7

Backed up data on the E partition. Solved the unallocated space problem as follows (everything in disk management):
1.Removed E partition (delete volume), so now I have a big chunk of unallocated space.
2.Created a simple volume using all of this unallocated space (again, call it partition E).
3.Reduced the size of this volume (shrink volume). This is the point where everything changed. Earlier, the E partition was a primary partition, shrinking it was also keeping it a primary partition; but this time the partition changed from primary to logical (I don't know why) and the space, that would earlier show up as unallocated, now shows up as free space. The partition E and this free space now forms an extended partition.
4.Proceed as usual to ubuntu setup, the free space is now usable.

I don't know how does disk management decide when to mark a simple volume as primary or logical (there is no option to change it explicitly), but it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.