2

I have changed my bash prompt in ~/.bashrc and have verified my character encoding is set to UTF-8. I am using the monospace font and Ubuntu 14.04.

Here is my ~/.bashrc
http://pastebin.com/009K2Kd6

This is what I am getting for the black right triangle:

screenshot

  • Please post your PS1= line from ~/.bashrc, obviously there's something wrong there. – kos Oct 13 '15 at 18:22
  • @kos Updated OP. – user0000001 Oct 13 '15 at 18:28
  • Works for me in gnome-terminal. Is that gnome-terminal? – kos Oct 13 '15 at 18:40
  • It breaks in the same way in xterm though. I suppose that's what you're using? – kos Oct 13 '15 at 18:42
  • 1
    Maybe check that Edit -> Profile Preferences -> Compatibility -> Encoding is set to UTF-8: changing that (pretty obviously) breaks the prompt for me. – kos Oct 13 '15 at 19:16
1

For those that get that strange invalid unicode character for the arrow, edit the following line:

local BRPT=$(echo -e "\xee\x82\xb0")        #UTF 8 Black Right pointing triangle

All is right with the world now. Also, fonts that go well with this can be found at powerline fonts

screenshot

  • Glad that you're happy with this solution, but this doesn't really solve the problem, it just circumvents it: \xe2\xae\x80 should be printed. – kos Oct 14 '15 at 14:17
  • @kos Just out of curiosity, what version of Ubuntu are you running? – user0000001 Oct 14 '15 at 14:18
  • I'm on 15.04. Have you tried just to purge / reinstall gnome-terminal by the way? Ah, and if you want to make a comparison I have GNOME Terminal 3.14.2 – kos Oct 14 '15 at 14:19
  • @kos Yup. Tried that originally but didn't work. – user0000001 Oct 14 '15 at 14:24
  • @kos Upgrading to 15.04. Lets see how this works. – user0000001 Oct 14 '15 at 14:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.