4

I'm using Ubuntu 14.04 LTS (Trusty Tahr) server:

Distributor ID: Ubuntu
Description:    Ubuntu 14.04.3 LTS
Release:        14.04
Codename:       trusty

I'm trying to install a minimal Ubuntu OS, but when I enter the command

apt-get install gnome-core

I get this output:

The following packages have unmet dependencies:
 gnome-core : Depends: eog (>= 3.4) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

After using apt-cache policy gnome-core eog, the output was:

gnome-core:
Installed: (none)
Candidate: 1:3.8+4ubuntu3
Version table:
     1:3.8+4ubuntu3 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages eog:   Installed: (none)   Candidate: 3.10.2-0ubuntu5   Version table:
     3.10.2-0ubuntu5 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

After forcing eog installation using apt-get install eog, the output was:

The following packages have unmet dependencies:
eog :
Depends: libpeas-1.0-0 (>= 1.0.0) but it is not going to be installed
Depends: gir1.2-peas-1.0 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

After that, using command apt-cache policy libpeas-1.0-0 gir1.2-peas-1.0:

The output was:

libpeas-1.0-0: Installed: (none) Candidate: 1.8.1-2ubuntu2 Version table: 1.8.1-2ubuntu2 0 500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages gir1.2-peas-1.0: Installed: (none) Candidate: 1.8.1-2ubuntu2 Version table: 1.8.1-2ubuntu2 0 500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

Then using command apt-get install libpeas-1.0-0 gir1.2-peas-1.0, the output was:

The following packages have unmet dependencies: libpeas-1.0-0 : Depends: libpython3.4 (>= 3.4~b1) but it is not going to be installed

E: Unable to correct problems, you have held broken packages.

After using command apt-cache policy libpython3.4 the output was:

libpython3.4:

Installed: (none)

Candidate: 3.4.0-2ubuntu1.1

Version table:

> 3.4.0-2ubuntu1.1 0
500 http://archive.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
    500 http://archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
 3.4.0-2ubuntu1 0
    500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

After using command apt-get install libpython3.4 the output Was:

The following packages have unmet dependencies:

libpython3.4 : Depends: libpython3.4-stdlib (= 3.4.0-2ubuntu1.1) but >3.4.3-1ubuntu1~14.04.1 is to be installed

E: Unable to correct problems, you have held broken packages.

After using command sudo apt-get install libpython3.4-stdlib the output was:

Reading package lists... Done Building dependency tree Reading state information... Done libpython3.4-stdlib is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

How do I resolve this issue?

0

1 Answer 1

1

Install the correct version of libpython3.4-stdlib

sudo apt-get update
sudo apt-get install libpython3.4-stdlib=3.4.0-2ubuntu1.1 libpython3.4-minimal=3.4.0-2ubuntu1.1

because libpython3.4-stdlib needs exact version 3.4.0-2ubuntu1.1 and not your installed version 3.4.3-1ubuntu1~14.04.1.

After that install gnome-core via

sudo apt-get install gnome-core

and install some uninstalled packages again

sudo apt-get install lsb-release python3 update-notifier-common

And at the end

sudo apt-mark auto libpython3.4-stdlib libpython3.4-minimal
0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .