On my new laptop (Acer tmp645-S-5275):

  • reduced windows 7 partition
  • installed Ubuntu 14.04.2 desktop 64bit on the unallocated space

On restarting, Windows starts normally.


  • started laptop with Ubuntu live
  • installed and executed boot-repair with errors

Here is the log generated from boot-repair: boot-repair logs

If I enable secure boot from BIOS, GRUB is shown but windows can't start.

Trying to start Windows from GRUB I get:

file path: /ACPI(a0341d0,0)/PCI(2,1f)/Sata(1,0,0)/HD(2,12c800,96000,f1a7390c70ad8b4b,2,2)/File(\EFI\Boot)/File(bkpbootx64.efi)/EndEntire
error: cannot load image.

If secure boot is disabled the GRUB menu is not shown and Windows starts normally.



When you installed Ubuntu in EFI mode with secure boot enabled you only can boot Ubuntu with secure boot enabled. You can solve your problem as described by following these instructions ->

First boot into Windows 7 OS and disable hibernation.
Open command prompt as administrator and execute:

powercfg /h off  

Shutdown the machine (do NOT reboot) completely.

Reinstall the GRUB bootloader to your Ubuntu installation in EFI mode.
Boot from the Ubuntu install media - then open a terminal and execute:

sudo mount /dev/sda6 /mnt
sudo mount /dev/sda2 /mnt/boot/efi
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
sudo chroot /mnt
grub-install /dev/sda

Note : sda = disk | sda2 = efi partition | sda6 = system partition | (taken from pastebin output)

Boot into BIOS and change the boot order in UEFI settings.
Select Ubuntu to be the default operating system to boot.
Now you can select which system to boot from GRUB menu.

You can check the partitions with GParted - the tool is included in Ubuntu installation media.
I strongly recommend to not use any 3rd party tools as they may bring along issues later on !

  • nothing change after update-grub – assistbss Oct 13 '15 at 11:46
  • @assistbss : Did you change the boot order ? – cl-netbox Oct 13 '15 at 11:47
  • Yes I did, but boot order is ignored. On boot I can see 'Secury boot fail'. Pressing any key on keyboard a boot manager is shown. The options are: 1. windows boot manager 2. unknown device Selecting the first option security boot fail screen is shown again. Selecting the second options menu grub is shown and, like before, ubuntu works and windows won't start. In legacy mode windows start normally ignoring ubuntu presence. This is exactly the same behaviour I had before update-grub. – assistbss Oct 13 '15 at 13:19
  • @assistbss : Please check whether there exists a switch in the BIOS / UEFI security settings where you can or will have to select and add the ubuntu efi boot file as being trusted - something similar to what was described in the provided link of olfred's comment under your question ! :) – cl-netbox Oct 13 '15 at 16:04

OP's answer, edited out of the question:

Here is how I solved this thanks to cl-netbox's and oldfred's help.

  • reduced windows 7 partition
  • in bios changed mode from legacy to UEFI (security boot enabled as default)
  • installed Ubuntu 14.04.2 desktop 64bit on the unallocated space (alongside windows 7)

In BIOS, in order to change security options I to set a password for supervisor user, so that every time I want to access to BIOS I have to enter this password, so I can have UEFI with secure boot disabled (this is the only way to start windows 7 pre-installed with UEFI enabled) and I can manually set the EFI file to list and sort as bootable items.

In security section of BIOS, I added the grub2.efi (under /dev/sda2/EFI/Ubuntu) file to UEFI boot manager database.

So finally in bootable items (in boot section of BIOS) I can see a new item related to GRUB. I just put it before windows boot manager.

Now the notebook starts from GRUB, and with secure boot disabled Windows also starts without problems after selecting windows boot manager from GRUB.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.